Cannot connect mBot via USB



I am new to the Makeblock and Arduino platform.
I have built the robot starter kit Tank and I am able to use the Bluetooth app to control it. So far, so good! :slight_smile:
However, when I connect the mBot to the computer (Windows10) with the USB cable, it shows no connections to the computer.
I have installed the Adruino drivers and mBlock 3.4.11. The mBot is powered on with the battery pack. I physically disconnected the Bluetooth module on the mBot.
I am not sure which Board to select in mBlock. I tried with several: mBot (mCore), Arduino Uno, Starter/Ultimate (Orion)
Nothing shows up in the Serial Ports list, its completely blank. At the top of the program, it says “Disconnected”.

I have read through many other forum threads trying to find the solution but nothing has worked so far.
Can someone please help me get the USB connection to work?
Thanks for any help! :slight_smile:

Cannot see COM port from mBlock 5 post firmware & mBlock update

The starter kit is the orion,

1, plug the USB in
2. select board - orion
2. power on the orion
3. turn the buzzer off
4. now you should see a com port when you connect

use this link


Thanks for your advice, but it does not seem to work.
I followed the 4 steps. The Orion gets power via the USB cable, but anyway, I switched it on to the battery pack and then turned off the buzzer.
I still cannot connect. This is what my device manager shows:Com%20ports
Any other advice?


I may be mistaken, but I thought there was a serial driver that had to be installed because the Makeblock boards use an FTDI chip for their serial connections. In mBlock, there is an option under the Connect menu that says “Install Arduino Driver” which sets up the driver for the Makeblock boards. You might try doing that to ensure that is not the issue.


Hello Chuck,
I have installed the Arduino drivers from the mBlock application. I have also searched and installed drivers via Arduino and mBlock support. I have the FTDI USB drivers.
But still cannot connect via serial port.
Do you have a clue?


Well, that would depend on who you ask. :wink:

Hmm, have you tried a different USB cable? Have you tried the other ports? Just trying to eliminate the hardware possibilities right now.

There may still be a driver issue as well, but at this point we need to loop in @tech_support.


What type of computer are you using? I am only familiar with RIM Virtual Serial Ports being used for Blackberry devices sold by RIM Canada.


Please kindly try chuckmcknigh’s suggestion, try other computers, other usb cable and other usb ports.
Also, you may try to turn off computer firewall and disable antiviruses, then try to reinstall mblock 3 again under default address (C drive).


Hello all,
I tried another cable and it worked!! Thanks for your help.
I did not suspect the cable, because the mBot got powered on via the “bad” cable, but still did not connect to the ports.
Now that is solved, I dive into the programming … :slight_smile:
Thanks again.

PS: the RIM ports are on my Surface Pro.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.