Cannot connect Mbot Ranger to Windows 10 with USB cable


First of all, I have no problems when I try to connect the Mbot Ranger to the computer with mBlock5 and USB cable if I am using admin accounts. But problem comes when our students try do this. They actually stuck on scanning the com port without anything show up. I have check the pull down list and sure that the software does not see the mBot Ranger.

However, I can see the com port being used for the connect even with the student account in the device management.


I have double checked everything and just cannot find the problem. Once I use an admin account everything go back to normal. Once I use a student account which definitely do not have admin permission, the problem happens.

Would anyone please kindly advice for the possible solution to this situation?
Many Thanks

Jason Kwok


I believe this is a permissions issue associated with where the software is installed. Are you using workstations that have local drives or diskless stations that are connecting to a server? If the latter, you will need to work with your system admins to resolve the issue. If it is on a local drive then it is likely a permissions issue. See this link for a similar question.


Thanks very much for the quick reply. This sounds really wired that I need to allow students to have administrator level permission. I guess I can only try creating a run as admin shortcut for the mBlock5 and put it somewhere for the students.

The setup of our computers are local drives and connected to MS AD server. Please kindly let me know if there is a better solution for this problem.

Many Thanks


I’ll forward that to the software team, but currently “run as an administrator role” when using a student account is necessary. Or have you tried online version-mLink?


Hi Makeblock forum Tech support.

I would just like to confirm that the “run as an administrator role” when using a student account is still necessary.

Is this still the case to date?


Hi, yes, it is still the same.