Bot firmware update failing at 4%


#1

Hi All,

I am trying to update the firmware of mbot and it fails at 4%. Any ideas? I updated the firmware of cyberpi, then connected it back to the mbot, but I continue to get the same error.

Error message:
The firmware update failed again.
Please make sure the device is properly connected. You can restart the device, connect it again and then try updating the firmware once again.

I tried the update from a pc and from a MacBook, connected through usb. I both cases mblock connects successfully to mbot. In both cases mblock recognizes that mbot needs a firmware update. In both cases when I click update it starts the update and it fails at 4% with the error message above.

If you have any suggestions please let me know.

Thanks,


#2

If your mBot is a typical mBot (not mBot Neo, mBot mega, etc.), the problem is likely that the mBot thinks that it needs to upgrade to this default firmware. There are two options on the mBot firmware update menu, one is the default firmware and the other is the latest firmware. These two conflict with each other, causing the mBot to think it needs new firmware when it doesn’t. This is a bug.

This may also help you:
https://support.makeblock.com/hc/en-us/articles/4410935367319-Firmware-update-for-mBot