Bluetooth controller Firmware


#1

Hello guy,

I have a bluetooth controller that worked well, but overnight, nothing.
It lights up and pairs, but nothing happens. Is it because of the firmware? An update is available but it crashes every time

Thanks


#2

Hi Jeremie,

Do you mean this Bluetooth controller?
image

Which product do you use to control through the Bluetooth controller? Is the problem that the robot doesn’t function when controled by the controller?


#3

Hi
Yes, this one. It’s not an on shelf robot, but with Me Auriga mainboard. I tried to add the new firmware but the android app shut down each time.
Is it possible that the old firmware of the controlle is not compatible with the new auriga firmware?

Thanks

Jérémié


#4

Hi Jeremie,

Did you try to progarm the Bluetooth controller through mBlock 5 software?
If yes, could you show me the program?

Actually, you need program the Bluetooth controller to make it work with the Auriga board. For example, here we have official example program for the Bluetooth controller and the mBot Ranger robot (the mainboard of ranger is auriga).


#5

Hi,

I use this program on Mblock3

This program is based on Mblock3 example.

Thanks


#6

Hi Jeremie

From your program, I see that you connect the electronic devices like smart servo, servo and gyroscop 3 axes modules etc with Auriga.
I may suggest that you simply your program to test these electronic devices without using the Bluetooth controller have a check. If all of these devices are tested ok, then you may adjust the program to test the Bluetooth controller with one electronic device one by one have a check.

Besides, you may download the official program example for the Bluetooth controller and Ranger robot base on mBlock 3 software . When you test the program, you can bypass the movement control part and test if the RGB LEDS and buzzer on the auriga board function to the command from the Bluetooth controller accordingly.
image


#7

May be a crazy question, but have you tried replacing the batteries?