Arduino C code not updated with respect to corresponding blocks


I’m trying to code my own blocks. After configuring the blocks , I coded it under the “upload transcode” area as follows.

I expected that code will appear and update whenever the blocks changing. but it appeared as follows.

I’m afraid that the place i am coding is incorrect. please help


Did you click “Save”?


Yes. I did. Please help, I worked so many hours to get the output.


what did you put in your header’s upload transcode? I have the same issue. I don’t know if that is becuase of the head.


Did you select “Arduino C” for “Transcoding language support:” in the “Transcode settings” tab?


I filled upload transcode section with respect to the blocks i built. Like below.


Yes Sir. I did. Also I clicked every “save” icons after editing


What is MagicBit?:thinking:


It is a Chinese document, but here is how to add a device.


Hi, I follow every step you showed below and the it works. The only difference is that I used Arduino UNO, instead of the MagicBit. Is that a device that’s officially supported by mBlock? How about check the bottom part of “Basic Information” section where you input the devices you wish your extension will support.

First try to test the same code with other available devices such as Arduino, if it works out. This cause of this issue might be the compatibility between mBlock and the devices.

Below are some screenshots showing you how the code works with Arduino UNO

and this is how the code section changes when blocks change:


Hi dai5_jp,

Now we have added English document for “How to add a device - Arduino” regarding your concern. Please refer to:

Supports in more languages are coming on their way.




Thank you so much for replying. MagicBit is the device i am trying to add to the mblock. That is built using ESP32. Actually I’m not sure that is not supported to the mblock.


Thank you dai5_jp. I tried that document. I could solve the problem because of you. But unfortunately the code was not uploaded to my device. ( I tried arduino_uno ID. I built an extension for my MagicBit device using mblock 3 version with help of arduino uno extension. That was worked correctly. ) I’m not sure that the reason behind the uploading problem is unsupported device ID.


After uploading below alert appeared. What is the reason behind this?


Hi Sadev,

How about disconnecting your devices first and reconnect it and repeat the uploading process? Sometimes it happens to my Codey as well, if there is no issue with the code, this method should work. We will also improve the stability of the connection.