Where are the APPS!?


Does anyone has any idea as to when apps will be actually available for doing some flow-based programming? At this point, all my son can do is connect and play. We don’t own an iPad and nor do we plan for one. Android based tablets surprisingly isn’t available, iphone not supported and even in my Windows 10 PC which has mBlock I am unable to use it with Neuron.


Hi bmninada,

The neuron APP support android based tablets. You can download the Neuron APP from the google store.
If you are going to use neuron with mBlock software, currently, only the experimental version mBlock 4.0.3 supports neuron.


Please let me know exactly what to search for in Google Store. I have tried and if you check Kickstarter comments few have too and could not find any app. In fact there’s a message in Kickstarter saying currently only iPAD App is available.

And thanks - for the heads-up on the experimental version. Appreciated. Will check and revert.


I have downloaded the experimental version. And found Neuron (top right corner).

Besides which also found connect. However, I see 3 options: USB, 2.4 and Bluetooth. Can someone explain how to use either of them?

Only in USB I see COM4 pop-up but software in the comp. not able to connect.
Nothing works for 2.4 and Bluetooth. Note: The PC I am using does not have any native Bluetooth support.


Hi bmninada,

Do you search the Neuron through the android based tablet directly?
If yes, on your tablet, please go to google play and search makeblock neuron have a try.

Once you still can’t find it, please kindly let me know.

Neuron not working with mBlock in Windows PC

Hi bmninada & Crackel

Please install this driver on your Windows 10 have a try.


That is the 1st I did. In my Samsung Galaxy A I went to Google Play and searched for Makeblock, Neuron, Makeblock Neuron in that order. Nothing for Neuron.

In Kickstarter page someone published an URL. I tried that too. States not available for my country: US. I believe you might be seeing the app as probably you are in China but the App does not seem to be published for US.


I have downloaded it however it’s a zip file. Also checked inside and found a readme.txt which doesn’t seem to provide sufficient guidance on how to install. Please provide instructions on how to install.
I have: Windows PC running 64-bit Windows 10 and the mBlock I have is the experimental version 4.0.3


Okay, thanks for your feedback, we will tracking the reason and make it available in google play in other countries. Please kindly wait for it.


For the driver, please unzip the file and you can find the install file under this path:


The install file does not work.
When clicking: VCP_V1.3.1_Setup_x64.exe OR VCP_V1.3.1_Setup.exe
"Error reading setup initialization file"

Unzipped the downloaded file and it created folder: STM32Virtualcom_driver. Inside which there’s AGAIN: STM32Virtualcom_driver. Inside which AGAIN: STM32Virtualcom_driver.
After that there’s:
STM32 USB╫¬┤«┐┌╟²╢» Virtual COM Port Driver(V1.3.1) folder
STM32 USB╫¬┤«┐┌╟²╢» Virtual COM Port Driver(V1.3.1).zip

I went inside: STM32 USB╫¬┤«┐┌╟²╢» Virtual COM Port Driver(V1.3.1) folder
Inside that found VCP_V1.3.1_Setup.exe and VCP_V1.3.1_Setup_x64.exe
Both of which did not work.
Here’s the complete folder path up to the location of the EXE files:

…\Downloads\STM32Virtualcom_driver\STM32Virtualcom_driver\STM32Virtualcom_driver\STM32 USB╫¬┤«┐┌╟²╢» Virtual COM Port Driver(V1.3.1)


Hi bmninada,

For the android neuron APP, please check it on the Google play again. It is suggested to search the makeblock and you can find it, please see picture below:

As for the driver issue, here I installed the same one on several Windows PC successfully. When you install it on your PC, is there any message about preventing it from installing?
Is it possible for you to take a video to show the whole process of installing. Thanks!


I thought I wrote what the error was: “Error reading setup initialization file” its a Windows generated pop up message.


You are looking at Google Play in your REGION - CHINA. The Neuron App is NOT coming up, here in US.


Its now available, as of yesterday. In US. Downloaded it.

Many of the buttons need work. For example - impossible to change hold duration, defaults to 3 second and upon selecting it doesn’t work.


Hi bmninada,

Glad to hear that it is available now.
For the button issues, could you kindly take a picture to show your program which would be helpful for us to locate the problem, thanks!


Hi !

Same problem as bmninada with the installation of the virtual com in Windows 10.

When clicking: VCP_V1.3.1_Setup_x64.exe OR VCP_V1.3.1_Setup.exe : “Error reading setup initialization file”

Would there be a better driver ???
I have a home version of Windows 10 in french canada…


Now they will ask you to take a video to prove it.


Hi Cracke l& bmninada,

We have forwarded the issue to our engineers. Will inform you when there is any progress.


My mBot robot works great with mBlock (version 4.0.3) on PC (Windows 10)
I assume that the problem is with the virtual port side?