Mbot 101 - Unable to upgrade firmware - Windows 10



We just mounted our little mBot 101 and tried to follow the tutorial to connect it.

  • connect USB select COM : port 3 ok
    (I verified with Devices & ports : on COM3, removing the USB cable; ports disappear no COM used in Windows Devices.
    Re-connecting it ; it appears well under COM3 BUT it DOES NOT say USB-SERIAL CH340 …
  • choose board mBot(mCore)
  • install Arduino drivers OK
  • Try to Upgrade Firmware : always failed.

Impossible also to Reinitialise, nothing else works.

I re-checked the COM port same as described above.

Was able to communicate via bluetooth with IPhone and use the phone as an remote.
Can anyone help ?
For info, we tried with 2 différents Windows 10 PCs …without no success…


The only mention I’ve seen of the mBot 101 is at this link.

Are you using mBlock or the Arduino IDE?

My normal sequence on Windows 10 for using mBlock is:

  1. Turn on the mBot
  2. Connect the USB cable
  3. Start mBlock
  4. Select Connect/Serial Port/COMn (where n is the port number. I’m only seeing COM5)
  5. Upgrade the firmware.
  6. Write and run programs.

I use the same sequence in the Arduino environment although I use the Genuino/Arduino board (I’m using an external 1.8x version of the Arduino environment and have set up my libraries for it).

On my Devices and Printers screen from the Control Panel, I’m seeing an icon at the bottom that says USB-SERIAL CH340 (COM5).

You might want to ask @tec_support for help. :-/

Fail to update firmware or upload code


Thank you for the prompt reply.
I’m using mBlock not the Arduino IDE.

In the sequence you mentioned step 5 always fails.
And in Devices and Printers I never sees: USB-SERIAL CH340…

THank you anyway …regards …


Hi Bigjaba,

The mBot 101 is a customize version which is different with our official mBot.
You can’t upgrade firmware for it by the same way, please refer to the way in this link to upgrade firmware for it.


Hello, Thank you very much for your advices.
1)- I run the post_install.bat:
—> I see USB serial Device but NOT Arduino 101 Serial monitor as said.
Using USB View: I can see Manufacturer : Intel
Product : 0x0409 : "GENUINO 101"
It is on COM3
2)- I modified the file UpdateFirmware.bat to change the com port to 3
save it
3)- run the updateFirmware.bat
It starts BUT stays at Waiting Device
I press the Master Reset button …but it doesn’t work until timeout…
I tried several times without success …
Do you have any suggestions to go further ?

Thank you very much in advance for your help …


Hi Bigjaba,

Please try upgrade firmware refer to this link instead.
Here I find another pdf instruction for this robot. Maybe it helps.mBot 101 Programming Manual.zip (664.5 KB)


Thank you very much for this new guide.
I will give it a try …

Thanks again.


I just want to add … I had difficulties in uploading the latest firmware.

The first issue I had was that I tried to upgrade using Bluetooth. Firmware upgrades are not done over a wireless connection because if they fail the result can be damaging to the device.
YET the manual does not explicitly say you cannot upgrade firmware over Bluetooth.

Second issue I had was that when connecting via USB I had 4 x COM ports on my Windows 10 PC. No matter what port I selected it was telling me it was connected. mBlock needs to know if it is connected to a known, supported, device. (Not sure why a device like this can’t just support native USB and not serial to USB)

Thirdly the default board was set as mBot(mCore) I just assumed this was correct but I have the mBot Ranger so I had to select mBot Ranger (Auriga) board.

The reason I mention the third issue is because of all of the forum searches, about firmware upgrade issues, this was never raised.


Hi kyone,

Sorry to hear about the issues you met.

Do you have the customized robot mBot? Or you met all the issues when upgrading firmware for your mBot Ranger?

Did you get it upgrade successfully finally? As for your suggestions, thanks for your feedback.
It is true that users choose the wrong board "mBot (mCore) " for mBot Ranger (it should be mBot Ranger (Auriga)).

Here I attach the the instructions about how to upgrade firmware for Ranger robot. How to Upgrade Firmware for Ranger.zip (358.3 KB)
Hope it helps for other users in the future.



I have the same problem with mBot 101 with Arduino/Genuino 101 and I can’t upgrade the firmware in mBlock, I have connecteed via com3, in my case. With Arduino IDE 1.8.3 I can normaly send program to mBot and it’s works very well but when want to do something with him in mBlock it dosen’t respond. If I upgrade firmware its stop on first package and its stop that with several minutes while I pull the master reset or reset button. If I upgrade firmware via updateFirmware.bat I have error "BLE firmware version is not in sync with CurieBLE library. Sometimes its also appears in device menager as libusb (WinUSB) device

It also show when I upgrade firmware:


Hi DamianS,

If you want to use mBlock to program mBot101, need choose the FirmwareFor101 from File Examples
MeBoard101. Compile and upload the program to your Arduino101/Genuino101
board. Please refer to details in this document.mBot 101 Programming Manual.zip (664.5 KB)



I tried to upload the FirmwareFor101, but when its try to copiles there is one error, which says, that found many libraries in Servo.h. Then its says that use: C:\User…\AppData\Local\Arduino15\packages\Intel\hardware\arc32\2.0.2\libraries\Servo
Not used: C:\Program Files (x86)\Arduino\libraries\Servo

Should I delete one of them or something like that?

If I delete one of them I see error:
“This library only supports boards with an AVR, SAM, SAMD, NRF52 or STM32F4 processor”



I found another Servo libary and now its works. What should I do to make the same program like in Starter example?


Hi DamianS,

Do you mean you want to program the mBot 101 with the same function in the arduino Starter program with mBlock software?
If yes, the Graphical program may not achieve it very well and we don’t have such example program too. You may challenge yourself to program it.



Now I understand you but I have another question: If I would like to make some program with blocks for Arduino/ Genuino 101 with which block I must start the program with Arduino program block or UNO Shield program or mBot 101 program?

And another question how can I upload the program? Because when I click upload to arduino I still have this bugs form screenshot


Hi DamianS,

If you want to program the mBot 101 with mBlock and upload the graphical program to the robot to make it work autonomously, you can use the UNO Shield program head.

For the issue there is error while uploading the program, could you paste the picture for your program and picture for the error?


Hi @tec_support

I was try do it just that like you said but robot is still no responding.

There are the pictures of program which was working when I choose the block “When green flag is clicked”.
I also have pictures of errors and everything that happens when I try to upload to Arduino.


Hi DamianS,

Is there any electronic module connected to the RJ25 Port 5 on the Me Uno shield.
Please temporarily remove all the other electronic modules from the Me Uno shield, then upload the program have a try.

Besides, make sure the serial port is not connected to other software opened like the Arduino software.

Since the mBot 101 is a customized robot, we don’t have a robot for testing. If you still have problem, please let me know, we will check if it is possible to apply for a mBot 101 for testing.


Hi @tec_support

No, there is no any electronic module connected to RJ25 Port 5. Should I connected something there?


No, the Port 5 should be empty.