Makeblock Laser Engraver Gallery-How to engrave the papercut


How to engrave the papercut?
This video tells you how Makeblock Laser Engraver create the art works.

Where to


Makeblock Community Team


Hello, I recently received the XY2.0 plotter and laser. I’ve mostly set it up. It’s awesome. However, I haven’t gotten the laser to work at all. I haven’t even seen it on at all. Do you have any recommendations on troubleshooting? I have gotten both X and Y movements with varying speed and stepping configurations; all I’m lacking is laser functionality. In starting the troubleshooting process I started with the M2 port. I actually think this is where the problem lies. I used a multimeter on it and can’t see anything on it. Please help. Thanks. paul


Dear @CandlerCustoms,

Thanks for purchasing XY 2.0 Plotter and laser kit. Please check the user guide here: Enjoy your art work and welcome to post your work here.
Let me know if you need other help, just email me (

Best regards!
Christina Zhang
Makeblock Community Team


Hi Paul, did you were able to solve your problem? Seems like I have the same problem, everything works fine except that the laser is not switching ON. I also tried with an external powersupply, the laser itself works fine so it is probably the M2 port…


Please refer to the FAQ Question 1.
Question 1
Why you cann’t upload the program?
Answer 1:
Please use this program to update if you are unable to upload the program successfully. Please find Arduino Tool.exe file in the unzipped directory. Open it as an administrator, open the firmware, choose the file Benbox_Laser_for_makeblock_leo_20140901.hex(or Benbox_Laser_for_makeblock_uno_ 20140901.hex)under the directory \Laser Engraver Upgrade Pack for XY-Plotter Robot Kit V2.0\Laser Engraver Upgrade Pack for XY-Plotter Robot Kit V2.0 software\Laser Version software\Rom.
Select the port and model, please choose COM11 and Leonardo, click upgrade firmware.


Hi Albert,

thank you very much for your feedback, it runs now!

I did that installation before, but it seems that the it is very important to to them in the right order:

  1. ArduinoTool.exe
  2. flush_firmware_for_makeblock_en.exe
  3. Benbox-Laser-Engraver-makeblock-2.4…

Best Regards,


Worked like a charm! Thanks a ton. The new documentation is much better than a couple weeks ago. Pictures to come as time allows.


Got it going! I was a little hesitant to throw the laser onto my power supply. After the reflashing the me board it worked great. Good luck with yours.

Another note: I detached the laser from the mount to correct the lens. The laser should be pinpoint narrow. Also don’t forget to adjust it at the height/distance it will be mounted at.


Hello, unfortunatelly the software: Arduinotool.exe is unresponsive at all and the laser doesn’t work. Where is the problem, upload tool or firmware?

My me borad version is 1.0 type leonardo. All is connected and checked like on image instruction.


Hello, Gerhard!
You can click on the site(, download the FAQs.
For Baseboard V1.0, please click on the download button, press the reset button board.
I hope that this document can help you solve the problem.
Best Regards,


Thank you for response, unfortunatlelly I have already tried reset buton but it doesnt work, I can see when I give the switch on command to laser that the led on board powers up everytime i click on the power on laser button in benbox, but laser will not switch on. In my case the arduinotool is unresponsive. And it not gives the right port COM35. There is nothing under COM11. Everything else works.

UPDATE: I have changed port to COM11 and made all the described steps but without success, except that the tool arduinotool.exe is now responsive (no graphical feedback but it uploads the hex rom). Laser still NOT switches on.


Hi @Gerhard,

Could you upload a screenshot of your Arduinotool? Did you try the Arduino IDE?

p.s, You don’t need find the COM11. The serial port is different with different computer and Baseboard.


Thank you for suggestion,
But it is unposible with Arduino IDE because this is firmware rom in hex format not a sketch. I have tried diferent ports also, COM11, COM35, COM37 etc. The diferent USB ports didn’t solved the problem. Now I am on looking for another tool to upload the provided ROM.


Finally, it works, firmware uploaded with third party-software. It works everything except the laser doesnt burn the paper. I can switch on the laser, weak on and strong on, I can see the difference too. I can move along the x and y axis. I can give the picture to print, it goes with laser changing the intensity but the paper remains blank althought there is the biggest value of intensity at 255. What could it be?


Hi @gerhard,

I think you mean that the laser is working but there is nothing on the paper, right? Could you try to slow down the speed of the laser diode?


I can’t test this right now, but I tried to use the settings from the tutorial pdf example, then I have turn the beam on max (255) and time on max and still nothing. I can register when I turn the time to max that cooling start to work. It is also registerble that by the pressing weak and strong laser button the beam becomes weaker or stronger. But it not prints on paper. I tried also focusing knob. I can only try to check the contacts on M2 port.


Finally everything ok, the problem for this last step was with focusing knob and speed parameter.But in my case I have uploaded the firmware with third party software. Both provided tools didnt work.


I am so sorry!
There may be a lack of certain parts of the Windows system files, making it impossible to install. We try to be compatible with all Windows systems.


really nice laser cuttings you may do with 3.5W laser on MakeBlock board