Mac OS X El Capitan


Just upgraded to OS X El Capitan. I had installed the USB driver and it worked fine for 2-3 days. The driver has now stopped working for as-yet unexplained reasons. I tried to connect via the 2.4G Serial connection, but that doesn’t seem to work either (did before).

I have followed the processes listed to reinstall the USB driver with no success, so I’m at something of a dead end right now. My biggest concern is that I had planned to use the mBot for teaching programming classes, but I don’t want to subject the kids to a lot of frustration because they can’t get their mBots connected on a reliable basis.

OS X: 10.11 (15A284)
mBlock: 2.2.1

Update: The issue seems to be that the WCH341 doesn’t have a signed driver and El Capitan (OS X 10.11) seems to be much pickier about that than Yosemite (OS X 10.10), likely due to the XCodeGhost attack. Even trying the link to set the operating system in developer mode doesn’t seem to work.

Any thoughts / guidance are appreciated.

OSX El Capitan: kext can't be loaded anymore because they disabled kext-dev-mode
Cannot get my MAC (or a PC) to recognize the XY Plotter Me Mainboard USB, Help!

Hi Chuck,

I had the same problem after updating to El Capitan. Before El Capitan everything worked perfectly…

I found the solution from this stack exchange thread:

Here’s the driver that worked for me: HL-340 / CH-340 / CH-341 Driver (V2.0.0). It costs $7.36 though:


Hi dcdcdc,

I’ve been speaking with Jeroem about his driver. He confirmed that Apple had changed something with the USB stack and is waiting for a response from them. He said I could try the patched driver, but that it might make my system unstable. Until it’s available, I unmothballed an old laptop with 10.7 on it to finish creating the programs for the class. Hopefully he’ll get an answer from Apple soon.

Are you experiencing any instability after installing the driver?




Hi Chuck,

I have not experienced any instability so far but I’ll let you know if I do. Things like this really make me lose faith in Apple for DIY projects…

Hope everything works out for you.


Just got the driver from installed and it allows me to communicate with a genuine Arduino (FTDI), but I still cannot get connected via the serial port cable. Since I have to teach a class in February, I sprang for an inexpensive laptop with Windows 10 (which seems to work just fine).

I’m with you on Apple / DIY projects. El Capitan is the worst breakage since Lion. :-/


I have the same problem… I have bought the el-capitan driver and can program my adruino nano (banggood clone with ch341) without any problems but no communication with the mBot.

and expose my child to windows was not my intention :smile:


found a signed (for yosemite and el capitan) driver for OSX that works with the mBot

found it here : (in German) (English)

direct url to the driver is here :

I removed the all the commercial drivers for the CH34x chipset installed this one and it worked !

mblock with mBot is now a success! (with Apple protection in tact)


I bought the ultimate robot kit for my child. I am told the issues I am having are ch34 related. Any Idea if this fix might work for me?
how do you remove the old commercial drivers? Thanks.


I do not what kind of problems you are experiencing and what kind of (commercial) driver is installed on your system so answering your questions is a bit hard (sorry)
removing the current driver is dependent on the manufacturer of the driver (and I do not know them all :wink:)
you could just try to install the above drive and see if it works…


I tried to install it. 3 times now. How do I know if it is there?


If you look in /Library/Extensions, you should see a directory named usbserial.kext (.kext means kernel extension) if it is installed. Although this page is for people installing a 3rd-party driver, it has instructions for what to look for and how to test things.


Chuck, Your suggestion to remove the other USB drivers worked like a charm. I had several others from specific vendors, and they were probably causing the problem. Now it’s easy to download arduino code from Makeblock to the bot. Thanks very much for your very patient help. Eric Frank


Hi Eric,

No worries, we’re all here to help each other. I’ve gotten suggestions from many others that helped me, so I’m happy to give back. :slightly_smiling:


This worked for me. Thanks!


I just tried to install the driver downloaded from this suggested zip file. However in El Capitan it still refused to install. Even after setting the security settings to allow installation from the App store and identified developers. Am I missing a step here?


Have you seen the remarks chuckmcknight made some postings back (on the 12th of Jan)


How do I “Remove all previously installed drivers”?


The unsafe way is to delete them from your system. The safer way is to move them to a holding directory in your home directory. I usually tar/bzip the driver and then store in an a local directory on my home directory called archive. Reboot and the new drivers will activate automatically.