Xtool D1 Pro 20 W wont power on


Hello everybody, new to the forum here.
I recently bought the Xtool D1 Pro 20 W 2 -1 Kit with IR head and some more attachments. I installed it all as per instructions, and just tried some test files with 20 W head, I updated the firmware as the Xtool software was suggesting and after that called it a night. the next day when I powered on the Laser, nothing, the light on top of the printer did not turn on, nothing happens, and the PC did not recognize it either. The only indication it has some sort of power is the blue LED next to the SIM slot. I tested both power bricks with my multimeter and it shows correctly 24v as it should. I have already sent a ticket to XTool Support, but it is the weekend.
I was just wondering did anyone have similar problems with their tools, and what might be an issue, what might cause this sudden breakdown.


Have you tried the xTool support page?


Same issue, started today. I was running a job and suddenly the windows usb unplug/plug sound, after the sound the laser returned to the home position. Eventually it refused to turn on for more than a few seconds.

Tried a different original power supply same result. This a video of the behavior. https://youtu.be/FTztnbvx6To


Did you try the link I gave you?


Opened a support ticket, waiting for resolution.


Also, you can contact them by email: