xTool D1 Issues: Skipping and Jumping over parts of images


We’ve been trying to use this machine for over two weeks. We’ve noticed that sometimes it starts skipping, jumping and the image starts getting off. We have to adjust all the speeds and power. Tired of wasting material. What are we doing wrong? It does not do it all the time.



Thank you for contacting us!
According to your description, if the engraved picture is offset, you can send us the picture of your work to locate the problem. Please also attach your PC firmware version information. ( Our after-sales team: support@xtool.com )



We also just got this machine (5w) and are experiencing the same problem. It gets part way into a bidirectional raster scan, then starts stuttering, with the imaging shifting slightly to the right each time. This occurs in a repeatable manner. It starts at the same time on the image, although the start position changes if you change the speed, appearing earlier at higher speeds. We contacted support, with a copy of the file and pictures of the result, and are awaiting a response. Did you ever get any resolution to the problem?


Have you tried xTool support?


This happens when one of or both of your Y axis belt tensioners hasn’t been locked properly after tightening the belt, the belt slowly gets pulled loose over time which is why it worked fine but then shortly after had issues.


Having a problem with my D1 pro 20 watt. x tool laser. When i try to engrave a large item over 180 setting speed no matter the power it starts to hesitate and click and does not want to work properly. The test pattern for what i am trying to run tells me to run at 375 at 30 percent power and i can not do that at all. When it is making the test pattern it has no problem. I know i have engraved large wood items before and had no issues even though this is not wood. So i am almost thinking this is a firm ware update issue or a software issue. belts are tight and everything is lubed so i am at a lost. love the machine i have finally figured out alot of other things lately on it to run but now this is happening please help.i also have checked couplings too. i took the laser off the slide and it still does it with the laser on the board only going side to side.


Have you checked the power supply, are you using all the recommended/proper accessories/parts?



Hi All,

This seems to be the same or a very similar problem to which I am having.

I have an XTool D1 Pro 20W and when I first got it, it worked brilliantly. Then after about 15 hours of engraving time the X-Axis appeared to start skipping, causing my designs to be completely mismatched and look awful. I contacted XTool support and despite claiming that nothing looked wrong from the evidence I sent over, they proceeded to mail me a replacement stepper motor. This arrived and was actually larger Y-Axis motor, not sure if this was a mistake on XTool’s end or if they knew that the original stepper motor wasn’t man enough for the task. Either way, I fitted this new motor and again, it worked for a short period of time and then has now started skipping and stuttering along the X-Axis but even more so than previously.

I have updated the firmware, tried a different power supply, checked the tension of the belts, all of the normal check and yet it has made no difference at all. I have contacted XTool support but last time they took a week to get back to me and then a week of conversing and then a further two weeks waiting for the motor to arrive - I’d ideally like to be up and running again sooner than then, hence this post.

Are there any suggestions on other things to try or is it a matter of awaiting a response from support and then a new board?

See link below showing the stutters (2x 150mm X Movements) as well as the misalignment faced previously (I’m not wasting material to get a new photo of this).


Link as mentioned - https://we.tl/t-M7ClOekGZD


Contact makeblock about the issue or see


And as Cal said, please check this:

Thanks for your time,


I was sure to lock the tensioners in place after I adjusted them - XTool support are sending me yet another motor promising that it will solve the issue.


@JackOrms02 Hopefully it will. Let me know how it goes!

Mention me as @Best_codes