Vector engraving and constant power mode


I have a D1 Pro 20W. I work with white tile method and I have an issue that in vector line mode at places where direction is changed the output quality deteriorates.

I assume the cause is most likely that the laser head decelerates/accelerates at those spots, so velocity is reduced, and the laser automatically reduces power to compensate. How can I prevent this or change the parameters of power reduction?

In Lightburn there is the “constant power mode” which I have enabled, but it makes no difference to the result. I have verified the output gcode – using M3 or M4 makes no difference to the result. Does this mean that D1 PRO has no support for switching into constant power mode?

Here is an example: a filled square surrounded by a line square – at corners of the line square the output is too low.


Not sure…
Have you tried: