Unable to use mBlock required by Makeblock app


#1

I just purchased a new Codey Rocky and downloaded the latest app in the app store for my iOS devices.

I was able to use Makeblock’s app for iPad V3.5.1 to control Codey Rocky. However, when I got to the code section, it instructed me to download mBlock. I downloaded the latest version of mBlock from the App store but it does not work at all.

I get to the Events section where it instructs to press the A button to make the robot say ‘meow’ but nothing happens when I press A. I verified that the bluetooth connection was established and working but it still does nothing.

Here are the details:

System: iOS (both iPad 7th generation Software Version 13.3, and iPhone X on 13.3)

Codey Rocky Firmware: 23.01.004.002 (indicates app is up to date)

Codey Rocky Product Model: MCR-K01-01

Makeblock App Version: iPad V3.5.1

I confirmed that I have the latest app and firmware and bluetooth is connected but I still cannot use the Code section related to the mBlock app. Can someone help with this? Thanks!


#2

Hi, can you please take a video for me?
By the way, is the Codey Rocky fully battery?


#3

Hi tech_support!

I think we got a similar issue… i tried at my iPhone this Jan 2020, and MBLOCK APP is not working…

Here is what happened to my case…

We bought a codey rocky, just this Dec 2019. We downloaded the MAKEBLOCK APP (i forgot the version) and installed it on our android tab. When we go to the Code Section, it opens its own coding environment, and we can upload the code to codey rocky, and it was working perfect. Note we have also downloaded the MBLOCK APP (i forgot the version) and installed it that Dec 2019; but we tried it last Dec 2019, but the coding upload is not working with codey rocky.

Now in Jan 2020, my son tried to program codey rock with MAKEBLOCK APP. This time when he goes to the Code Section, the bluetooth got disabled and open the MBLOCK APP coding section, and the code upload to codey rocky, is not working, anymore.

Can you advise on how to resolve this issue?

Thank you very much!


#4

Hi Makeblock,

My problem : Post
Hi Makeblock, I will continue in this post because I am in the same situation with my Cody Rockey at Firmware.

iPad Air 2 Wi-Fi + Cellular (model A1567, IOS 13.3, : Makeblock application everything is functional
with the mBlock app, you cannot connect to Bluetooth. However, I have already done a lot of code with mBlock on IOS.

  1. Check in the Bluetooth of my iPAD works. Yes, the Codey Rocky connects in the Makeblock application and my Bluetooth headphones.
  2. Firmware compatible with Makeblock APP, test but does not work
  3. Latest firmware (23.01.013), test but does not work.
  4. Android everything works
  5. PC everything works
  6. In Android and Bluetooth settings, I see the robot
  7. In IOS and Bluetooth settings, I don’t see the robotà

Note: All of this on the new mBlock v.1.8.2 version that I updated a few days ago


Problem mBlock IOS and Bluetooth
#5

I checked my firmware and it was the exact version specified on the mBlock application. (to work with the Makeblock App)

Everything was configured correctly and connected via bluetooth but still did not work.

Codey Rocky Firmware: 23.01.004.002 (indicates app is up to date)


The Firmware was the problem. Today, I connected Codey Rocky to the computer and checked the Update button on the mBlock app for Windows, the firmware version was different (23.01.013 as you indicated).

I clicked to update the firmware and once it was 23.01.013, Codey Rocky started working.

There are 2 options to set the Firmware. The 2nd option does not work at all (Firmware compatible with MakeBlock App). See image below.

That was the firmware my device was on. You should probably remove that completely as it doesn’t work at all.

image