New User - Need Help


I just purchased and assembled mBot.

I connected the mBot to mblock on my MacBook.

I added a device for mBot and it connected OK via USB cable.

I tried to Update Firmware. It ran to 100% and then said firmware update failed.

The mBot does not work with the remote at this point (even through I put a new battery in the remote).

I can’t do anything with the mBot right now.

Appreciate any help you can provide. Thanks.


Hi @rose_gardens ,

The error you are getting usually means that either the serial connection was not established or that the wrong board has been selected.

  1. Which version of mBlock are you using?
  2. Which version of MacOS are you running?
  3. Did you install the FTDI driver and reboot?

Be aware that with Mojave, you will see two devices for the same serial port in the connection menu (or dialog if you are using mBlock 5). You need to select the one that has /dev/tty/wcusb***, not the standard /dev/tty/cuusb***.



Chuck - Not directly related to this post, but I am trying to find out how to buy more mbot boards. They are listed in the products on the Makeblock website but when I click to order one, nothing happens. Amazon lists many makeblock products, but not the mCore board itself. Do you know of a place where I can order several of them? Maybe tech support can help? I can’t find a way of communicating with them. Thanks, Eric



Thank you for your email.

I am running mBlock v5.0.0-RC.

My operating system is macOS Sierra Version 10.12.6

The port it connects on is /dev/tty.wchusbserial/14510.

What FTDI driver do I need and where do I find it?

Thanks again.




Further to my last post, I tried to follow the instructions are this url:

I installed the driver for CH340 as instructed at that url but it did not help.



Hi Bob,

Hmm, very odd. Here are the steps I use for mBlock 5:

  1. Connect mBot to computer via USB cable.
  2. Turn on mBot.
  3. Launch mBlock 5.
  4. Delete the Codey device.
  5. Add the mBot device.
  6. Click the connect button.
  7. Select the wchusbserial device.
  8. Click setting (gear icon at the bottom).
  9. Click upgrade firmware.
  10. Click the updates button on the dialog that pops up. (Note: the mBot will be disconnected after the update completes).
  11. When the update is finished, I restart the mBot to ensure a proper cleanup of memory.

From that point, I’m able to upload programs to the mBot.

Could you try those steps?





It worked!!!

Thank you so much.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.