mBlock on Chromebook stuck on compile/upload


I’ve had varying degrees of success with mBlock on Chromebooks but not seen this before. Flash runs fine and mBlock loads up but as soon as I upload a program it gets stuck on the compile / upload window that pops up and won’t go further.
I waited a few minutes with it spinning there and no luck. I’ve also reset and updated the firmware of the bot I was using but that didn’t help either.

Does anyone have a fix for this?


Have you installed mBlock ChromeOS client or web version?
Was it working fine before with Chromebook?
Is there any error message when issue happens? Can take a screen shot of that for us?


This is what I was using
I hadn’t used this Chromebook before.
I don’t have access to this Chromebook anymore; an error message didn’t appear but I suspect it may have if I waited longer, I didn’t have a lot of time when it happened.

Sorry thats not a whole lot to go on.


Well, that is not very easy for us to analyze.
If you try a non-chromebook, is it working? Or other chromebook?
If it is convenient to you, please give us more details.

Makeblock Editor Compiler Issue

This is a picture of the issue. At that point it had been like that for about 15 minutes.

It was taken on a different chromebook but it is the same issue.

Using the same mBot on a PC works fine, I’ve tried resetting the default program and upgrading the firmware on the bot to test as well but no luck with that.


Hi Moose,
The screen shot is not very clear. But it seems that you were using web version, right?
We are checking the issue with software team.


I don’t quite understand. I’ve gone to mblock.cc/software/ and under the ‘mBlock 3 for PC’ I’ve tried both the Online Create option and the Chrome OS option.

The Chrome OS option takes me here:

I have downloaded this and when I open the application it takes me here:

The online editor takes me to the same online page:
but prompts me to download the app from before:

They both do the same thing. Is there another way I’m missing?


Ok, I’ve made progess with this issue. It’s to do with the firewall we have in place, which I should have realised sooner tbh.

@tech_support In order for me to sort this firewall problem out I need a list of URL’s to send off to be whitelisted.
So far I have editor.makeblock.com/ide.html and from poking around there is also an arduino.compile.makeblock.com? Are there any others that are required for the application to function properly?


A mi me pasa lo mismo ¿ Cómo solucionarlo? pues mblock 3 me parece más completo que mblock 5 o mlink para chromebook ( que sí me funciona)
¿podéis ayudarme a instalar mblock 3 en chromebook?