mBlock crashes


Hi!, I’m new to mBlock(v3.3.2), which is running on Windows7. I downloaded it and tested some basics ok. Then just clicked on the “connect” tab and the program just stopped working.

It hapens only on that tab bofore showing the scroll-down. I say this because the same thing happens if I first click on any other tab whose scroll-down menus would show ok; but then, as I try to move the mouse pointer on to the connect-tab (to see its scroll-down menu), mBlock crashes as well.
Here is the crash-event description:

Name of Problem Event: APPCRASH
Application Name: mBlock.exe
Application Version:
Application Timestamp: 55de0777
Fault Module Name: KERNELBASE.dll
Fault Module Version: 6.1.7600.16385
Fault Module Timestamp: 4a5bdaae
Exception Code: e0434f4d
Exception Offset: 00009617
OS version: 6.1.7600.
Regional Config.ID: 11274

Thanks in advance for all help!


I’ve been running it on Windows 7, Windows 10, and Mac OS X 10.11.x with no problems.

Did you install the proper Arduino driver?


Thanks for the help!.. I found that it works fine in my kid’s PC… Problem is just in mine… I tried installing drivers manually (runing Driver_for_Windows.exe from the drivers’ folder of the mblock folder)… Gratefull of any advise. Otherwise, I will just move on to my kid’s PC.


Hmm, a crash in KERNEL.dll usually indicates something at the OS level has gone haywire. You might want to try reinstalling mBlock if the reinstall of the driver didn’t fix it. You might want to check with @tec_support to ensure that you have a current driver for the Winchipahead USB chipset. I found one link here.


No luck, but thanks for the help; I’ll just get going on to my kids’ PC.


Did some Googling and found this link that seems to indicate your User Profile has been corrupted. It also mentions the Microsoft Fix-It tool that can correct the error. You might have a go at seeing if this fixes your issue.


I encountered the crashing problem. Several things went wrong before it happened. First, my usb connection is not working. The upper corner states “connected” but it immediately said “disconnected” after I pressed Upload. Second, there were “errors” in the lower right Arduino box when uploading. Third, mBlock started to freeze. Finally, it crashed when I connected the usb and turned on mBot. I was able to restart my computer but the program keeps crashing whenever I try to make connection. I did try the old trick of un-install/re-install mBlock and Reset and Upgrade Firmware on mBot. But that did nothing.


Weird. The errors with the compilation box are likely due to not being connected. I had a similar issue (I’m using Mac OS) and had to install an updated driver. You might ping @tec_support to see if there is a new Windows version of the driver.

I’ve run mBlock 3.4.6 on Windows 10 with no issues, but my set up may be different than yours (e.g., anti-virus, etc.). Does your USB connect to other devices? Also, have you tried a different cable? Sometimes that makes a difference.

I am also assuming that you are connecting to the correct serial port as well.