Blue tooth not connecting


#1

Hi - I have an MBot that we purchased earlier this year, and I am not able to connect it to the bluetooth on my iPhone 9 plus.

I have deleted all other bluetooth devices from my phone and I have tried the MakeBock app and the mBlock Blocky app. The blue light is flashing, and it has new batteries.

The controller that it came with works.

I have not done any firmware updates

thanks


#2

Having tried to do a firmware update - I have not been able to do this, as when I plug the bot it - it does not seem to register that it is connected, the only Serial Port option that I have is dev/tty.Bluetooth-Incoming-Port.

thanks


#3

Hi HenryKC,
Have you tried to use another phone? Your phone is iphone 9 plus? As we never heard Apple released iphone 9 series. Here is FAQ download, please kindly refer to 31.
For firmware upgrade, please use usb cable connection, and you need to install driver, which can be referred to faq 1.
Hope that helps.
By the way, your mBot is Bluetooth version, right?


#4

Sorry, I meant iPhone 7 plus

With regards to the firmware upgrade -I can not seem to check the serial port on my iMac as I can not find Device Manager

How do I know if its a bluetooth compatible mbot? on the wireless module section of the board - there is a unit that has asmall blue flashing light , and on the opposite side to the blue flashing light is a small white button


#5

Hi HenryKC,
You can check your box, is it saying 2.4G version or bluetooth version? And if it is 2.4G version, there is a small usb dongle. 2.4g version doesn’t support bluetooth. If still cannot confirm that, please take photo of “wireless module” you mentioned for me.
Check serial port on iMac, go to “about this mac”–“system report”–“network“, or you can also google it.


#6

Bluetooth connecting issue is the common problem and this is happen because it is work on radio wave and radio wave is not visible. You can take help from McAfee customer service for the solution.