[solved] Latest Marlin for mElephant printer


The problem

I downloaded Marlin from http://download.makeblock.cc/data/melephant/Marlin.rar

Link is provided in the mElephant description ​http://makeblock.com/melephant-3d-printer​ ​

But it is not working at all - I also found many complaints on the internet. Z axis is moving in opozite direction, auto level is not working and so on.

The question

Could you provide the link to the latest/development version of the Marlin Firmware?

mElephant print head hits the print bed

Hi gpson,

Please check your mElephant printer, does it has the flexible coupling or not? show as below picture:

if your 3D printer has the Flexible coupling ,pls use the firmware:

if there is no flexible coupling, please use this firmware.
SH1106 Opanel-coupling.zip (1.4 MB)

SH1106 Opanel-n-coupling.zip (1.5 MB)


Thank you! Now everything is working.


I am getting this error when uploading to the Melephant, " using typedef-name ‘fpos_t’ after ‘struct’ ". I am using version 1.8.2. Thanks ahead.

Best regards


Please compile and uploade the marlin firmware with Arduino 1.6.5 have a try.


I could compile it and upload it. But now the printer is making a bip sound when i turn it on. Any ideas.

Thanks ahead


I found this 3. Marlin (SH1106 Npanel,T6.5,Lead 3).zip (1.3 MB) on another forum thread. And I got it to work. But is this the most recent firmware or is their another version ?


Hi technologi,

There were three versions of marlin firmwares for no coupling elephant printer.
Normally, we try them one by one, I can’t tell which one is the latest now since the mElephant printer has discontinued a period of time.


Is there a way to get this links to work again? I think i need other firmware. Which Version is the Marlin-Firmware?


Hi DerBaer,

Could you send a picture for your mElephant printer? Does it have the Flexible coupling or not?


Its the one without coupling.


Hi DerBaer,

I will send three versions of mElephant firmware to your email address via the pCloud transfer website.
Please keep an eye on the email from pCloud transfer.

You can try them one by one with your mElephant.


I tried to flash, but everytime i get this errors…

Flash_errors.zip (1.8 KB)


Hi DerBaer,

Please try the Arduino 1.6.5 software.


tried this with all of the firmwares, but i got errors while compiling.
u8glib is installed.compile_errors.zip (1.6 KB)


Hi DerBaer,

The error message pop up while you compiling the firmware or upload the firmware?
Here I tried compile the three firmware and all of them can be compiled successfully. You may check the settings on your Arduino software have a try.


Thats a new Installation. I only set type of board and Com3 for connection. Also i installed the u8glib. Thats all…



Ok got it, i reinstalled Arduiono without u8glib.
Now it works.

Thank you for your help!