Getting started with mBot and a Mac


@chuckmcknight We did it! Thank you so much! Internet is becoming a better place because of you!
(Will bother you again…maybe!)


@chuckmcknight The driver seems not “stable”. After initial success, the driver is then gone! I can’t see it under the directory! I tried to install it again and it won’t appear under the directory which means the driver is not properly installed. Anyway the program we did is follow the line.


@chuckmcknight very frustrated! Not available again!!


@chuckmcknight had an one-on-one session with customer care people using Chinese social media Wechat. Found the problem! I have to switch on the mbot to get the connection!

My other question for you is: do I need to wipe off the previous code that was uploaded to the mbot? Seems my mbot is not doing well at avoiding obstacle. Cheers!


Hi Oliver,

You can reset default program and see if the avoiding obstacle work properly.


How do you do that? Thx


Hi Oliver,

Please refer to the steps in this link:
Since you have Mac PC, please pay attention to Note part.

Any more issue, please send email to


Are you Kevin?
Just tried and found the reset choice is not available…(in grey, not black). Do I need to start a new project?


Hi Oliver,

I am Daisy from Makeblock.

Are both the options grayed out (Reset Default Program, Upgrade Firmware)? Did you choose the mBot as Board and chose the correct serial port for mBot? Kindly send a picture.


Hi @Oliver_Li,

To reset the mBot to factory default, you will need to have the mBot turned on and connected to mBlock. When you have properly connected the mBot, click the Connect menu. The upgrade firmware and Reset Default Program menu options should be available at this point. I usually upgrade the firmware followed by resetting the default program to ensure that everything is properly cleared out of memory. Normally the contents of the mBot’s memory will be overwritten when you upload a program, but sometimes there appears to be residual data that just needs to get flushed out.

Hope this provides some help.



Hi Daisy, I found the problem why the choice is not available - 'coz the mbot is not connected to the computer. However, after I did all the above (update firmware and reset to default setup), the mbot is not working properly (Supposed to avoid obstacle, but it acted strangely, the previous program of following the line didn’t work either) @chuckmcknight


Hi Oliver,

While you reset default program for mBot, you connect the computer to mBot with USB cable or Bluetooth?
Please note: the bluetooth connection is only for wireless program. If you want to upgrade firmware or Restore default program for mBot, please disconnect the bluetooth connection and connect the mBot to PC with USB cable.


OK, will try it again! Thx!


Hi Daisy, the same problem happens. Maybe there is bug in my program. I wonder if I can email it to you, for you to have a look! Cheers, Oliver
PS: I am emailing this project to Kevin.


Hi Oliver,

Okay, please send it to


Hi to everybody.
I have this problem: after using mBlock 3.4.6 on iMac with macOS 10.12 (Sierra) for a month without ANY problem, I’ve used mBlock in Arduino mode to control a servomotor. From that moment Arduino refuse to upload any sketch from mBlock in normal mode and run ONLY in Arduino mode. What’s my error? What can I do?
Many thanks


Hi belphouse,

Which makeblock robot do you use?
What is your program, can you paste it here? Do you mean you can’t upload the program to the robot? Please make sure you connect the main board to PC with USB cable when do upload.


Hi, txs for your quick answer. I don’t use any robot but I connect my Imac with an Arduino Uno Board. After have run a program in Arduino mode I wasn’t able to run any program in normal mode. I’ve clicked on Upgrade Firmware in Connect mand the problem disappears by itself. I seize the occasion for signal a little translation error in italian version: the block under Arduino set named “set pwm pin … output as …” has been translated as “imposta l’usita PWM …”; the correct spelling for “usita” is “uscita”, as in the block just above. Anyway, many many congratulations for your work: finally I’ve found the right tool for my teacher activity!!


Hi belphouse

Glad to hear that!
The italian translation is from one of our customers. Since there are some mistakes for it, if you don’t mind, could you please kindly help modify the parts which are incorrect, but please don’t modify the other part which may have different language habit.
If it is okay, you can request the modify permissions on the Google files in this link. Thanks!


Thanks for your helpful instructions! (I wish the actual mBot website included them). Unfortunately, this doesn’t seem to have helped at all (on Mac OS X Sierra). Still not seeing any new serial ports in the Connect menu.

Honestly, super disappointed in this product, that’s supposed to be a kids introduction to programming. At this point it’s’ just a super-expensive remote-controlled car.