Getting started with mBot and a Mac


I have seen that with an other (commercial) ch34x driver – I was able to program an Arduino clone but not the mBot
did you try it with the driver I pointed out to you?

(before you install this driver; delete the previous one from the system)


When I install that driver, the OS tells me to configure the device, and it has it listed as a modem. I’d like to get this working on my older macbooks. I’m trying to teach a course for elementary school kids in a few weeks.


I believe that is standard – and it does not matter what you enter as all settings will be overruled by the mBlock program


See this thread for a link to the latest CH340/CH341 driver. That seems to have corrected all of my issues. with El Capitan.


Still not working, I installed the drivers (Arduino_Driver_for_MacOSX) I see the cu.wchusbserial410 in /dev when I connect, but when I launch mBlock 3.2.2, serial menu has no options. If I try to connect as a null modem in the OS, I get an error saying that I can’t esablish a connection to the ppp server.
I’m on OSX 10.6. Any help would be much appreciated. Everything works fine on my PC, but on my mac I have nothing but troubles.


To be honest, I have an older Macbook that I was using with Lion and I think all I needed to do was the signed driver hack mentioned earlier in this thread. I’m seeing /dev/tty.wcuserial410 in my menu. You will also need to ensure that no other drivers are installed in /Library/Extensions. As mentioned in other threads, the Prolific driver is often the culprit, so either delete the director (extension .kext) or move it elsewhere if you want to be safe about not losing anything in it. The USB drivers seem to not coexist very well with each other. :slightly_smiling:


@asha, the Upload to Arduino block appears if you click on the mBot Program block or go to the Edit menu and select Arduino mode. You will also notice that some of the block palettes are greyed out or missing some blocks because mBlock does not support those for Arduino.


I upgraded to El Capitan and everything is working now. (My 2008 MacBook is the oldest supported - I just made the cut :slight_smile: ) I did my robot class a few days ago and the kids loved it! Screams of joy for turning on a few LEDs. pretty cool!


Still couldn’t connect my mBot to my Mac! Tried all these. Maybe I made it wrong when using terminal?!


Hi Oliver,

Did you remove any extra USB drivers? That is usually the cause.


To get Bluetooth working on the Mac:

  1. Go to the Bluetooth preferences to pair the mBot with OS X
  2. Open mBlock
  3. Select /dev/tty.Makeblock-ELETSPP from the Serial Port submenu under the Connect menu

Just pairing will show the mBot as being disconnected because pairing will only make the serial port available.

Also, be aware that you have to be connected with the USB cable if you are planning on uploading programs to the mBot for standalone operations.


@chuckmcknight Many thanx for the tips! Will try it tonight!


Hi Chucky, please clarify : you mean other drivers installed or…


I found your earlier post re: drivers on Mac

Terminal is absolutely uncharted area for me. I tried and still couldn’t connect!!! Grrr! See below


Hi @Oliver_Li,

Terminal is the easiest way for me (I’m an old Unix guy though). Here’s the best I can do for a step-by-step:

  1. Open the Terminal
  2. Change to the extensions library: cd /Library/Extensions
  3. Run the following command (you will be prompted for your login password*):

sudo find /System/Library/Extensions/ /Library/Extensions/ -name osx-pl2303.kext -o -name osx-ch341.kext -o -name usb.kext -o -name ProlificUsbSerial.kext -o -name ch34xsigned.kext

This will show whether you have any conflicting serial drivers.

After installing the WinChipAhead driver, you should only see usbserial.kext in the /Library/Extensions directory. If you see anything like ProlificUsbSerial.kext or something else with USB in the name, I would suggest that you move them to a temporary folder in your home directory. A reboot should ensure that the correct driver is loaded on your system.

From there you should be able to connect the mBot with the USB cable, turn on the mBot, and then connect via the serial port on /dev.tty.wchusbserial410.

  • You must have administrator rights to do this


@chuckmcknight Many thanx for this…I almost gave up! Tried with wife’s Dell…Unfortunately the laptop is a company one and we don’t have authority to install any software.


Hi Chucky, how do I do the step #2?
Just type cd /Library/Extensions and return?
Still not good!


Install this?!


Not showing at all :frowning:

Mbot/osx problems: upgrade firmware not working

Hi @Oliver_Li,

Yes, once you open the terminal you are working at the Unix shell (command line), so you will need to type in cd /Library/Extensions to change to that directory.

To see if the directory is there, you can type: ls

This works the same as dir under Windows. If the extension is installed, it will have a subdirectory (mine is named usbserial.kext). If not, double-click the CH34xInstall.pkg (make sure it’s the one from the sengotta blog) to install it, then recheck using ls.

Hope this gets you further along.