Getting started with mBot and a Mac


Hi…my parents just gave an mBot for Christmas and I cannot wait to get started. I assembled and tested my mBot using the manual mode and it seemed to be functioning fine. I then connected it to my Macbook using OS X 10 but alas I found that it was unable to detect the serial or wireless connections. I downloaded the latest version of mblock application software (scratch version) and all I can see when I click on “Connect > Serial” is /dev/tty-bluetooth-incoming-port. It does not offer any other options. The “upgrade firmware” option is also gray and cannot be activated. I checked out the Youtube videos on how to connect mBot to the computer and tried to follow the instructions but I am not able to see the bluetooth device either. I assume that neither the cable nor the bluetooth connections are working. I asked my dad to help me and he tried it on his Mac as well (OS X ElCapitan) and could not do any better. I really hope someone out there can help me. I am only 12 years old and do not know much about computers. It would help if you can give me step-by-step suggestions that I can try. I can pull my dad to help me too:)


I also got a mBot for Christmas too. I assembled it and can operate it with the remote control but can not connect it with my father’s Macbook Pro or with his Samsung smartphone by using bluetooth or by connecting it directly with the USB socket.

I want to code it like it says and don’t want an expensive remote control car!

Any fixes?


I also got this mBot and it is not working with mac os 10.10. Bluetooth seems to connect but is not really conneted to software. Please do something or I give this thing back.


same here. can not connect to bluetooth on the mac. help


I had the same issue and installed this driver:

after this I am able to connect via USB.

Bluetooth was working once, since then I cannot re-connet to bluetooth (prior and after installing the above).


look here:


Only thing that worked for us was the mbot app from the appstore. This way you can at least apply some code. I really want the bluetooth to work but alas it does not. Very disappointed right now.


Thank you to the users here who tried to help me. I tried the new driver route but it did not help. I tried the online chat with the company but it seems to be manned by people who don’t know much. They ask the same question again and again and after 45 minutes I was exhausted and gave up. The quality of their support is awful. I would recommend that parents think long and hard before getting kids this product. In my case it was more frustrating and I would have preferred NOT getting this gift. I will stick to Lego Mindstorm because I know it works. I am telling my friends in my robotics club about this bad product for sure.

How to find a mBot using Bluetooth From Mac

My 10-yr-old son and I are new mBot users. After some exploring, we are successfully using mBlock on a Mac running El Capitan to program the mBot.

After installing mBlock and connecting the mBot to your computer, you won’t see the correct connection under Connect>Serial Port because you have to install the mBot driver, and there’s an extra step required to do this installation if you’re running Yosemite or El Capitan. Here’s what you do:

Go to the official mBot driver page:

Click the Download ZIP button on the right.

This will download a folder called: Makeblock-USB-Driver-master

Double-click on this zip file in that folder:

This produces an installer called: CH34xInstall.pkg

Ctrl-click on this and choose Open. Then continue with the install.

The driver still won’t work because of security measures built into OS X Yosemite and El Capitan, so you need to follow the instructions at the bottom of that GitHub page where you downloaded the driver. For El Capitan, restart and press CMD+R as soon as you hear the startup sound. This puts the computer in recovery mode. Under Utilities, choose Terminal. Then enter this command in the terminal window, followed by return (single space after enable):

csrutil enable --without kext

Then do a normal restart (no CMD-R).

Now, switch mBot off and disconect the battery power. Launch mBlock on your Mac. Plug USB cable to mBot and computer. You should see LED on mBot showing USB power. Turn mBot switch on (more LEDs light). A window for opening Network Preferences should appear on your Mac. Click Cancel. Now when you go to Connect>Serial Port you should see this second option:


Choose that option and you now have a connection to your mBot that enables you to upload your Scratch program to the mBot by clicking on Upload to Arduino. You get a progress window when you do this. When done, switch mBot off, disconnect USB, reconnect battery pack, and switch on.


Thank you very much for your help. I think your advice and step-by-step guide helped me. I am not there yet fully and have two questions. First, I see in the Connect>serial port>/dev/tty.wchubserial1430 Is it okay to select this? Second question, after I get scratch started up and a sample program loaded on the desktop, I do not see any option on the mblock application that allows me to “Upload to Arduino”. Where is that hidden? Thanks again for your help. I am glad to be moving in the right direction at last.


HI I’m also 12 .

If you are in a robotics club then you know not all robotics kits are going to be easy to build. It’s what makes robotics fun! My friend he is 10 years old and he got the mbot to work in 15 minutes…

:smiley: Please , don’t blame the people of mbot and call the mbot a "bad product " only because you can’t figure it out.

Nice people here can help you.
Legos are fun but they are easy the mbot is really cool because it is hard!! smiley:


So to answer your first question, you should be fine to select that serial port.

In order for you to be able to find Upload to Arduino, first make sure that you have selected the option “mBot” under Boards and under Extensions in mBlock. Then select Robots under the Scripts tab on the left side of your mBlock window. You will now see all the things mBots can do! The important thing for you is to click on a roundish block at the top that says “mBot Program.” Once clicked on it will change your interface a bit. If you look at the top right of the window you will see a button saying “Upload to Arduino.” Click that to upload your program! Start simple and good luck!


Thank you VERY much for your help thirdlion. I benefited from your advice and now I have my bot working. I even wrote a short program to check things out. Thank you for your all the good advice.


You’re always welcome!!! :smile:


Hello !

Thanks to the answers in this topic, I succeeded to connect my daughter’s mBot with my mac running Yosemite. Nevertheless, I cannot connect the mBot with her 10.6.8 Macbook : no device shows in the “Connect” menu and the Bluetooth is greyed out.

I tried the solution with the Terminal command : the serial preferences dialog box shows but still no options in the Connect menu.

I’m running out of solutions and options : thanks for your help !


This procedure, even if it works, is ridiculous. This product is aimed at novice users, not IT professionals. It should JUST WORK!.

The Mac version of the software needs to be greatly improved.


I followed the directions on the GitHub page for Yosemite, but it didn’t seem to work. I suppose I need more step by step instructions for Yosemite. Any ideas?


I agree.


@dietzj: this is due to the in Yosemite:available and El Captitan: enforced driver signing
in Y you had the possibility to ignore driver signatures and in EC you do not have that luxury anymore.
Apple enforces that a person/company that makes drivers now signs there driver to make it hard for malware and virus makers to attach itself to key (and possible dangerous) parts of the operation system.

turning off that mechanism IMHO is very bad since you disable a key security feature.

that is why I did my best to find a signed driver for OSX 10.11 (that possible also works on 10.10 (Yosemite) if you look 10 postings above your posting you will see another posting from me :smile: in that posting I’ll point out the place on the Internet where the signed driver can be found (Works for EC and possible also for Y) and this driver is free.

maybe the folks from Makeblock can contact this manufacturer and ask if they may include the driver in there software.
my 2 cents


Similar experience here. I was able to connect to the MBot on my MacBook Air running El Capitan at home.

However, at school, our iMac desktops do not connect or ‘see’ the MBots. They do see and connect to Arduino boards, so it it is not a cable/port issue.

This system simply does not play well with Macs.