DC Motor Connector Angle


I have the IR Starter kit and everything is working well, except for two problems, both with the motor.

I first constructed the tank and the power from the motors was really low. It wouldn’t move unless on level 7+ for speed, and this was on a completely fresh set of batteries. If I put it on carpet, I needed to set the power level to maximum (9). This isn’t like the off-roading I see in the videos. Not that that’s the point…I’m eager to start playing with the code…but should I be getting more torque from my motors? Or is this normal?

Anyway, I decided to swap to the three-wheeled car, thinking that the added treads and wheel might be the problem and simpler is better. However, the power connector to the motors is angled differently from the assembly instructions and can’t be attached. I have the newer version of the 6V mother, with a plug that points perpendicular to the drive shaft (as opposed to two leads that I’ve seen on videos that point parallel to the drive shaft). The picture in the instructions suggests that this plug is rotated 90 degrees from the vertical orientation of the screws, but that is not the case. So, when assembling the car, my power cable to the motor goes either straight up (zero room to plug the cable as there is a blue bar there) or straight down, dragging along the ground, even with some tight wrapping. The instructions suggest that the plug should be pointing forward or backward.

I took apart the motors to see if I could reorient the external screw holes to a 90 degree offset from the plug, but that doesn’t seem possible. I can only flip it a full 180 degrees, which does nothing. So, is there a fix? Or did the person solder the power plug incorrectly?

Thanks! I love the kit!

Improving Makeblock (Call to the Community!)

Hi @dante,

I’m very sorry for the motors. The torque of the motor is too low. We will help you change that for free. Where did you buy the kit? From our website or our distributor?

And could you upload a picture of the drive shaft?


Thank you for the response…and I’m sorry for the delay.

The kit was a Christmas gift, so I don’t have any knowledge of where it was purchased. After further testing, it really does seem like the torque of the two motors is very low and not the same. When I remove the wheels, use the lowest power setting from the remote, it barely turns alone… just a bit of a hum.

I can’t attach an image because I’m a new user, but link is here: http://imgur.com/a/k8soS

As you can see, the power connectors go “up” when attached to the bars as necessary. There is no way to adjust this by 90 degrees as necessary for some builds…or is there?


This is interesting, I seem to have the same problems: pcb on motor turned 90 degrees and too weak motors.

Your specification http://www.makeblock.cc/dc-motor-25-6v-185rpm/ says the motors should have torque of 1.5 kg.cm What is the torque of the replacement units? Will the 6 AA batteries give enough power?

Can I apply for a replacement too (I bought from an Amazon reseler)


Hi @Michal_Benes and @dante

I’m very sorry about the problem or DC motors. Please buy 2 new motors on the website and leave a note in the comments.(Like “Johnny knows this…” or something). Then tell me the order number, and I will change the price to 0 in the system.


p.s I’m sorry but we have the Chinese new year holiday before 2/26. I will ask my colleague arrange the deliver ASAP we they get back.


Hi @Johnny,

Happy Holidays! Lets talk after the New Year.

At this moment I actually own 2 kits (the starter and ultimate kit). RadioShack had some very nice discounts on the ultimate kit (after all they are bankrupting now :frowning: ) - I got one 2 days ago. The ultimate kit DC motors seem to be even slightly weaker than the starter kit ones. I am buying 12v accumulator and I want to test the motors with it, hopefully it will have enough power. But before I order 4 new DC motors I’d like to understand what is going on. You guys should communicate more about this. Are the motors bad? Was this a wrong type of the model? Was it your supplier mistake? The lack of communication undermines my trust in your dedication to quality.

Also, to give you honest feedback, please see also my other posts in different threads. My whole experience with your product was a very mixed one. There are some good parts but also many small bugs/incompatibilities or shortcomings of the documentation. (E.g. you do not seem to be updating Scratch and Android app firmwares to keep them in sync, your git sources are different from the direct downloads etc.) All those things combined make it pretty hard to set up your robots (even for an experienced SW engineer). By looking at the forums I am hardly the only one. I think you are doing something great (e.g. I really admire your dedication to opensource and open HW) but I feel like being your beta tester.

On the bright side, if I resolve the motor problems I’ll have exactly what I was looking for and I may forget about my initial negative experience. My son loves the tricycle robot. He already learned to program it using Sifteo cubes:

(a custom thing I programmed for him)



Robot Starter kit Bluetooth firmware update

The 12V accumulator arrived today. It seems to be strong enough to turn the tank easily and I do not see the voltage drops that were resetting my board before. I am still unsure where was the problem before. I had 6 new Energizer alkaline batteries. Does it matter what type of batteries I use? Do you think they were bad? Or is the motor problem? I am suspecting that 6AA batteries is not enough to power the robot.

See my post here for the photo of the accumulator I am using.


Hi! New to the community here.

I just bought and assembled the tank robot (IR model, but switched to bluetooth) with my son today, and spent all morning trying to figure out why it wouldn’t turn! Eventually realized it was because of what folks have been saying in this thread, weak motor couldn’t handle even the tiniest bit of carpet! It can’t even turn well on hardwood with power turned all the way up. Is the only solution here to get bigger motors? Or is there something actually wrong with these? I was happy to see I’m not crazy and that others are having this problem.

I’m sad the little guy isn’t working, but I will say that everything about it is awesome :slight_smile: I also bought the electronics kit, and am enjoying that as well so far.



First off Michal… Great project there for your boy, and I love your hardwood floor.

I have also ran in to the same problems described about the mounting brackets and the motor torque. I went online found that Duracell’s rechargeable seem to have better umpf and tried those, but in my 5 year old is not able to do much on my hardwood floor. Forwards and backwards are okay, but turning with out forward movement is not possible. I am looking at the 12v battery pack that Michal described (Michal please see my post). I did want to mention that here in the states there are a lot of Vapor (E-Cigs) stores that sell TrustFire 3.7 Li batteries at different mAh. I saw a post about creating a battery pack of those. It does sound as though a 12v pack may be the way to go, or are the mortors just not working as designed? I also purchased my Ultimate Robot kit through Radioshack. Please let me know if there is anything you can do to assist with the poor performance of my kit.


Hi @Michal_Benes,

I’m sorry about the uncleared information of the motors before. There is some mistake about the production process of our supplier. However, we have fixed that problem. All of our guys would come back in these 2 days. I will upload a complete report here later.

And you could see that the voltage of all the 25mm motors is 6V. And the voltage of 6 1.5v alkaline batteries is 9v. So it’s enough for the motors.


Hi @stevo,

Thanks for your support at first. If you have the same problem of motors, you could buy 2 new motors on our website (http://www.makeblock.cc/dc-motor-25-6v-185rpm/) and leave a comment about the exchange thing (like “Johnny knows that…”). Then I will change the price to zero in the system. Thanks!


Hi @nine,

If you have the same problem of motors, you could buy 2 new motors on our website (http://www.makeblock.cc/dc-motor-25-6v-185rpm/) and leave a comment about the exchange thing (like “Johnny knows that…”). Then I will change the price to zero in the system. Thanks!

p.s Did you meet the same problem in Ultimate Robot Kit?


Hi @Johnny,

thanks for the response. Is it fine if I wait with the order a couple of months? I’d like to order few more components together with the motors. What about the DC Motor-37mm 12V motor in the Ultimate Kit? It is a next month birthday gift for my son so I didn’t have a chance to test it yet, I tested the 6V 25mm motors though and they were bad.



Thanks Johnny for the information. I am not sure if the order I put in for 2 6V motors worked as it wanted to charge my CC, then i went back and added a comment and it disappeared after that. Let me know if I should try again. When telling the arm robot to go forward that would mean you are trying to provide power to, 2 x6V motors, a Bluetooth Module, 1 Orion block, all that weight, I have not tried to measure the load, but it seems like too much for the 6AAs. I have tried higher end batteries and even purchased some 2450mAh AAs It must be something with the motors. My kit was the Ultimate Robot Kit purchased from Radio shack.

With your 12V battery running the the 37mm 12V 50rpm motor you should be able to pick up just shy of 400g(13-14oz) before the belt slips, but you have to make sure the belt is tight and properly aligned. I am speaking about about the stock arm robot design that comes with the Ultimate Robot kit. I think if I modify the bot some I could probably lift more. As a matter a fact I found a youtube video with Makeblock folks showing off their stuff and their arm robot there seems like a better setup. That motor seems functional even with the 6AA battery pack of course when you use it only 1 motor is running.


Hi @Michal_Benes,

I think the DC Motor-37mm is functional now. And it’s ok if you want to buy something others, and you could make the order any time you want. Just tell me the order number after you finish.


Hi @nine,

Theoretically, if one of the voltage is 1.2V-1.5V, 6AAs should be enough to drive 2 6V motors and the electronic modules. All of them is in parallel.


@Johnny, the 1.2V for accumulators or 1.5V alkaline batteries is just the nominal voltage. It will drop under load (especially when the robot is accelerating).


Johnny though I agree with your theory there, I do hope you are taking in to account the output voltage vs the electrical load. The load impedance when both motors are trying to engage at the same time will… in my opinion dramatically reduce. Of course I also can’t get my motors to run just left or just right so that part is just not enough power all together. So I went and bought a brand new set of 6AAs, I get 7.4v, eek if that is what I am getting from the batteries at the Walmart then I am afraid that might be an issue as well.


Hi @nine,

We have tested it many times before, so please trust me – The motors are abnormal instead of the battery issue. You could order 2 new motors on our website for free.


Will do that.