Level 7-3


#1

Hi,
we can not solve level 7-3. can someone help us?


#2

Hi, here is the correct commands to pass this level.


#3

Excuse me guys… level 7-3 of what?


#4

Hi Dutes,

It is the mBlock APP which has many program games for mBot or mBot Ranger.


#5

Hi,
For some reason it is not working for us. When we run the code, the lights turn red before we even lift the mbot.
How do I know if the sensors are working properly?

Thanks


#6

Hi Carlos,
Sorry for the late reply. This level depends on Line follower sensor. I will send you an email with the guidance for testing the line sensor.
And did you use non-english as the phone system language? We tested with English that is working.


#7

Hi! ty for responding. So I tried the instructions provided with no luck. The sensors are ok, as they turn on and off as I block them or do not accordingly.

Then, as the FAQ mentions I checked the cables to be in the right position, but still no luck. Then I followed the directions on the FAQ to reset the program. So I installed the software and updated the firmware but it still does not work.

I have also checked that I am using the right instructions and yes, they are correct.

Any other suggestions?

Thanks!


#8

That is too strange. To figure it out, can we have video call via skype? This is my account live:stephanie.wu_10
I work from 9:00 am to 18:30 pm, Mon-Fri, China time. I am not sure if it is convenient to you.

By the way, when you try with 7-3, pick up the mBot, did line sensor light change (should be off)?


#9

Hi!

Yes I will add you to skype, Im sorry it took me long to respond.

To your question, yes, the sensor lights do turn off when I pick it up. Its very weird, its more like the problem is in the coding, not in the bot. as I was writing this I just realized that on our software we do not have the repeat bucle available, we have only a forever available. Could that be the issue?

Regards!


#10

Hi Carlos,
In level 3, we should unlock “repeat” block under “control”. Would you confirm that again?
Or please add me in your skype and let me know when will be convenient for our video call.


#11

Hi!

Im sorry I haven’t responded. So I am confident there is a problem with the software because the help menu recommend to use the repeat block, but in the control menu there is no repeat available, furthermore, there is never a repeat available, not even in create mode.

Attached pictures:
https://drive.google.com/file/d/1DS17AvVysDIX671ksRhuy4r--Chuo8mp/view?usp=drivesdk

https://drive.google.com/file/d/1DTC3Fr5sS5ouUOo4_IFjF9SrNiiP4GFg/view?usp=drivesdk

https://drive.google.com/file/d/1DWb6P4Zey2shfupvS0QujIDwdI0NuIFS/view?usp=drivesdk


#12

Hi carlos,
Maybe you can post screen shot here as I have no permission to view your google drive pictures.
In your mBlock software (on ipad, this app is called mBlock Blockly), could you check the app version please?


#13

There it is! Thats the only available control on the Control menu. As you can see there is only forever and the if decision.

I will share the software version in a little bit as I don’t have the tablet here in the office.

Thanks!


#14

Hello Carlos,
Sorry the previous screen shot may be the earlier version which uses “repeat”, actually this is same as “forever”. It should be translation update. I have replaced the screen shot with below one:


#15

Hello,

I have the same problem, can you please send me the instruction to test my line finder too please? I think it’s defect because I have no blue lights on during its on the table on a white paper.

I bulid and connect everything as I should. Exception was the Ultraschall sensor. This have bigger distance. I put some of this white plastics between sensor an the front part of the bot. Maybe this influence the line sensor because it’s a bit over this?

Best Regards
Van Hardt