Programs don't run


Hi all. I just assembled the robot with my son, and hardware seems to work well, at least using the IR remote control.

We tried to generate a very simple program. We were able to connect through USB. We used Arduino mode to upload the program to the robot (operation seems to succeed), but nothing happens. We tried several actions, like restarting, pressing buttons, and re-uploading, but nothing happens.

Another problem we are facing is related to firmware upgrading. Although we are able to upload programs, firmware upload always fails. I also tried to reset the default programa to mbot, but I get the same message: upload failure.

We are really frustrated about this, because I couldn’t find any detailed topic about running programs in the documentation, and the forum discussions didn’t help me to solve the problem or understand what we are doing wrong.





The normal sequence is:

  1. Connect the mBot via the USB cable.
  2. Select the appropriate serial port from the Connect menu within mBlock.
  3. Upgrade the firmware.
  4. (Optional) Reset the Default Program from the Connect menu within mBlock.

If you are uploading your own programs, you will need to do steps 1-2 and then upload your programs from Arduino mode. I wrote a short eBook that covers the basics of using mBlock and the mBot available at this link that you may or may not find useful.


Hi Chuck, thanks for your message. I discovered that the cable that came with the problem was bad. I used another cable and the upload succeeded. I will take a look at your documentation anyway. Best regards, Gustavo


I hate it when it’s as simple as a bad cable. :slight_smile:


I too am having a problem with uploading a program from the mblock software to the Orion board. I have followed all the instructions I can find on how to upload. I have reinstalled the software, restarted the program, computer etc. Every time I try to upload it tells me the upload failed please remove the Bluetooth module. I don’t even own this module. It kicks this message back with just the motors connected. Please help.


Hmm, without seeing your setup it’s tough to say what might be going on but generally speaking if the upload fails its because you do not have a serial connection (USB) to the board. It sounds like mBlock might think it’s connected via the Bluetooth module, so be sure to select the correct serial connection in mBlock. Some quick thoughts:

  1. Make sure you are connected via the USB cable. That’s the only way to upgrade the firmware, upload programs, etc.
  2. Make sure the board is powered up, i.e., the power switch is on.
  3. Make sure you have selected the correct board in mBlock.

Not sure what version of mBlock you are using, but if you are not using 3.4.8 I would recommend getting it.

Not sure what platform you are on. If you are on Mac OS, you will need to install a special driver (link). I haven’t had a problem with Windows 10, but I think there may be a special driver for it (search the forums).

Screenshots or videos of what’s going on would be helpful. :slight_smile:

If you still can’t upload, contact @tec_support.


Hi dbryan729,
Did you ever get your problem solved? I am having exactly the same issue.

  • The program runs in online mode.
  • The program cannot be uploaded to the Arduino. the system pops up the following message: “Upload failed, please disconnect the Bluetooth module”

Ideas, comments, solutions are welcome


Hi carlospfr,

You may refer to the steps in this instruction to upload an example program.3. How can I upload my mBlock program to the Orion (589.4 KB)

Please note: keep the Port 5 on Orion board empty while upload program for it

Me auriga Direct drive of solenoids from outputs 1234. Is it possible?

Thanks for the file. We figured out the issues the other day.

  • Online mode lets you work in ways that cannot be handled by the Arduino alone. Part of our problem got fixed when we changed CHARs by FLOATs. We did not change definitions or types in the C script. We just replaced words by numbers at the MBlock’s graphical programming interface.
  • If Mblock is not well installed, problems won’t get fixed with an update. It did not work right on my laptop until I uninstalled it and installed it again.
  • Yes, the same error will be displayed if the Bluetooth module is plugged in at Port 5. At the events log, it is seen that something happened when trying to read the Arduino’s flash for double-checking, after uploading. If the program is good, and the MBlock is installed correctly, the Orion will get the program, and the program will run fine despite the error message.
    Hope this helps to other father & kid teams. Good luck and best wishes


Great Job!
Thanks for sharing that!