Nervous Bird cannot move from Android App


The first project I built was Nervous bird because it was the most simple.

Initially when I connected it to an android mobile phone, (and selected Nervous Bird) when I pressed turn left or right it would “slowly” turn in the correct direction. When I selected forward or reverse it would not move forward or reverse.

I installed the latest version of mBlock and updated the firmware. Now it won’t turn left or right when connected to a mobile phone !!

The bot has new Energizer batteries. I tried on two different mobile phones and the same result (phones were different manufactures and different versions of android but both are above ver 5.0).

When I selected the standard ranger and picked up the bot and pressed forward both wheels turned forward in the correct direction. All directions seemed to work ok… it is as if only Nervous Bird does not work.


Not sure exactly what the issue is, but I had to replace my alkaline batteries with rechargeable LiPos to get the mBot Ranger to have enough power to work.


Hi kyone,

In addition to Charles’s suggestion, normally, you need reset default program when you want to control the robot with Makeblock APP.How to Reset default program for (411.1 KB)


I have brand new Energizer advanced. The motors have full power and everything works except it won’t move in any direction. As I said before it use to slowly turn left and right but after the firmware upgrade it doesn’t even do that any more.


I tried that… it didn’t fix the issue. Could it have something to do with this latest version of the app ?


Hi kyone,

Do you mean you tried reset default program not upgrade firmware?
As for the Makeblock APP, do you use the Makeblock APP version ? I have done the test with this version APP and it works on my Android device.

For the battery part, how long it has been used? The Ranger robot is a high power robot which consume the power in battery very fast. If it is possible, we’d still suggest that you use rechargeable lithium battery (7.4v is ok) for the Ranger robot.


The document you suggested I follow says “Upgrade Firmware: click Reset Default Program->mBot Ranger under Connect.”

The first thing I did was to update the firmware. The second thing I did was to Reset Default Program.

Should I not have updated the firmware ? Should i try and install an earlier version of the MakeBlock program and update to older firmware ?

There were no clear instructions in the Manual that came with the robot.

I am using Makeblock APP version

The batteries are new, never been used before. I have only used the robot for a total of 10 minutes. I have 6 more new batteries to install again if you think that will help.


Hi kyone,

You can see the difference between upgrade firmware and reset default program in FAQ number 7 in mBlock FAQs.

Normally, there is no need to update to older firmware since you have reset default program for Ranger robot with mBlock 3.4.8.

If you have other totally brand new energizer batteries, please try them.


I changed the batteries… still does not work.

When I change to Dashing Raptor or Off-Road Land Raider they appear to control the wheels in the correct direction.

I will build the Off-Road Land Raider and just let my kids play with that build for now.


Hi all,

I got the same problem here, Nervous bird just do nothing when press the control UI.
It just stand self-balancing only move a bit when i quit or exit the Nervous bird interface.
Android App version.
mblock for PC version 3.4.8
firmware version 09.01.014


Hi mmaaxxii,

Do you mean the nervous bird won’t move forward/backward/ or turn left/right when you press the direction joystic on Makeblock APP?

Did you reset the factory default program for the Ranger first?
Once still the issue with the factory default program, could you please take a video to show your operation and the behaves on the nervous bird?


Only now i have just dismantled the nervous bird and built the rover bot. The rover bot works fine. We would have all lost interest if the rover also didnt work !

As for nervous bird, when i first tried it, it would only turn left and right, slowly. Not forward or backwards. When I updated the firmware and result default it would not move at all, not even left or right.


Yes, i tried reset default program many times also tied upgrade the firmware from 09.01.013 to 014.
i can never upgrade it to 09.01.015 even i disconnected bluetooth on all my mobile devices.

btw, not able to upload video here.
please use the below dropbox link,

Many thanks,


Yes, i tried reset default program many times also tied upgrade the firmware from 09.01.013 to 014.
i can never upgrade it to 09.01.015 even i disconnected bluetooth on all my mobile devices.

btw, not able to upload video here.
please use the below dropbox link,



Hi kyone & mmaaxxii,

We have confirmed that there is some issue with the nervous bird control panel on the Makeblock APP.
The next version Makeblock APP will fix the problem. The next version APP may be published next week, please kindly keep an eye on it.


I had installed Makeblock APP onto both an Android phone and tablet… The APP never worked on the tablet but worked on the phone. I now have the latest version on the tablet and it is now working 100%. Using the large screen on the tablet and having extra features opens up the usability of the devices and more enjoyable to use.