Move block palette does not work in German mBlock


Both on Android and iPad, the Palette of Move blocks does not work: When I click to open the Move palette, there is just one Move block without the normally shaded backdrop; also, this one Move block cannot be dropped into my block program. When I switch the iPad language to English, everything Looks and Works fine. This is obviously a bug.

Is there any Workaround (other than switching the language) or bug fix?

Thanks in advance for your Support.


Hi Stefan,
Here we test the latest version mBlock APP in German on an iPad, the blocks under Move are normal and work properly.

Do you use the latest mBlock APP v0.8.4? If yes, please kindly take a screenshot for the commands under move (in German).
Besides, may I know the model number of your Android device, and model number of your iPad?


Hello, thanks for looking into this. Here is some additional info on the problem:
mBlock Version: 0.8.4
Android: 7.0 or 5.1.1
iOS: 10.3.2
I just recognized that the problem appears after I connected to the mBot Ranger the first time. After a fresh install and before additional content for the Ranger is loaded the Move palette looks fine. After 1st connect and even while disconnected the screens on all devices (iPad, Androids) look like this screenshot:

Thanks in advance for your support.

Regards, Stefan


Hi Stefan,

Thanks for your info.

The Android: 7.0 or 5.1.1 and iOS: 10.3.2 are the system version, may I know the model of your android and iOS device?


the models are the following:

  • Android 7.0: Huawei P10 lite, Model WAS-LX1A
  • Android 5.1.: Model Huawei P7-L10
  • iPad: MGHX2KN/A

Does this help?


Hi Stefan,

Thanks for your info!
We have tried your operation and verified this problem on the APP now.
Thanks for your feedback, we will let you know the updates once it is fixed.


Thanks for looking into this. Any indication as to when this could be fixed?

My 9-year old son just got the Ranger as a birthday present and is enthusiastic of building his own programs (he was a bit disappointed that the most important Move part did not work).

Looking forward to your feedback!


Hi Stefan,

We understand that! This has been provided feedback to our product manager and will update a new version asap. Will inform you when get the expected settlement time.


Hi Stefan,

This issue is caused by the translate problem. Do you mind to enter our APP translate platform and help us translate part of German? This would be helpful for us to solve this problem quicker.

Best Regards!


Hello, thanks for the suggestion. Not sure whether I understand correctly: Do you suggest I contribute to your app translation that, if I am not mistaken, you are performing on, right? Not sure what this would mean for me in terms of efforts. And not sure what the actual translations have to do with the bug that you just found on integrating the translations. Maybe you can elaborate on this.

But I am always happy to contribute to improving products I (or my son :slight_smile: ) uses.

Regards, Stefan


Hi Stefan,

Yes, you understand it correctly. We need your help for the German translation on the mBlock APP.
It is so nice of you. I will contact you via email with the detailed info for which we need the help. Thanks a lot!


Hi tec_support, I just send my contribution of German translation. I hope this is helpful in resolving the bug in the mBlock App.

Regards, Stefan


Hi Stefan,

Thanks so much for your help.
Yes, we have updated the new mBlock APP, you can just enable the network function on mobile device and open the mBlock APP, it will updates automatically, please check it.
Feel free to let me know if there is any problem.


Hello @tec_support, thanks a lot for the quick resolution. I tried the mBlock app on iPad and Android and everything looks fine now: the app performed a few seconds update and all Move blocks are now there. :smiley:

Thank you and regards


Hi Stefan,

Glad to hear that!
Thanks for your help and feedback!:grinning:


Hello @tec_support,

I just found that with fixing the Move blocks apparently one of the Control blocks was damaged in German mBlock: the repeat forever Block (see screeshots attached) does not have the bracket to include the blocks to be repeated, so it became useless. You can work around this using a conditional repeat with a trivial false condition in the open development space, but it is blocking to continue in the tutorial space beyond 4: (ultra sonic) exercise 6 (see screenshot).

Please fix the repeat block so that my son can continue the tutorial.

Thanks in advance and regards


Hi Stefan,

Sorry for the trouble caused.
Please open the mBlock APP again and see if it works now.


Hello, this was quick. :+1: Yes, it is working again. Thanks a lot.
Regards, Stefan