Mbot ranger land raider will not move forward and only beeps


I feel like I have invested my hard earned money in yet another toy that does not work. I bought my daughter mbot ranger for Christmas. She used the scratch coding to program it. The first day it was working, now on day two it will only go forward a bit then stop and beep. Help please. Frustrated mom & Daughter!


Hello Grob,

maybe the batteries are dying. Have you tried using fresh batteries? I am using rechargable batteries myself, but according to another post on this forum the mBot Ranger does munch alkaline batteries.

PinkyPepper (https://www.youtube.com/channel/UCtVRNnOm-70dMkJt9vUSGWA)


I haven’t tried replacing the batteries. They were brand new and we only used the mbot for one day, maybe a total of a few hours. This seems odd that batteries would only last through one use. Rechargeable batteries are expensive, I wish I had known this prior to purchase. This was the only Christmas gift my daughter received and we just want it to work. :sob:


Hi Grob,

Sorry to hear that!
The mBot Ranger is a high power robot which consume the power in the battery fast. So, from your description, the robot can’t get enough power from the battery.
According to our test and research, it is suggested to use rechargeable Li-ion battery or rechargeable nickel-metal hydride, nickel-cadmium which can be bought from amazon or local shop. Or Alkaline battery with good quality like Energizer, DURACELL (but non-rechargeable battery can’t last long).

Sorry for the trouble. You are a loving father, hope you and your daughter have a most happy and prosperous New Year!