Mbot not moving while usb is plugged


Hi everyone!
I need help with the following. I have just bought an mbot for the kids. So far everything seems to work fine. I have tested all the sensors on PC and via Bluetooth as well without any issue. However, when the USB cable is plugged and a try to set the robot function to “run forward at speed 50” or “set motor M1 speed 100” an run the code, the mbot kind of freezes and gives a continuous beep sound. Everything else works fine while plugged and run, like the leds are changing the tone works on the speaker, the ultrasonic sensor and line follower give back values. Only the motor not working. My question is that is it normal? Btw, if i connect the mbot via Bluetooth, then the motors work fine in test mode as well.


Hi Bontoo,

I’ve never tried to drive the mBot around using the USB cable. But I do know that with my batteries, the mBot doesn’t drive well at speed 50. I need to use at least 75 before the mBot starts driving, otherwise the power is too low to get the mBot moving. So maybe choosing a higher speed could help. Just a suggestion. I don’t know if it really helps in your case.


PinkyPepper (https://www.youtube.com/channel/UCtVRNnOm-70dMkJt9vUSGWA)


Hi PinkyPepper!

Thank you for the reply! Yes, indeed that was the issue. i set the speed only to 50 and actually i need at least 79 to make it move. But it works now! :slight_smile:


Thanks! I am happy to hear it works now.

I hope you and your kids have fun with your mBot!