Mbot connection chromebook


problems to connect the mBot with USB on chromebook.

  • first problem: chromebook doesn’t find the mBot
  • after restarting the app, i can make a connection but it is impossible tot upload a program, upgrading firmware works perfectly and even after upgrading firmware, i can’t upload a program
  • when i click on ‘upload to arduino’, de popup window compiling appears but nothing happens…

I spent the whole summer writing tutorials and everything worked fine, now nothing works.



Hi henkjs,

Thanks for your feedback!
This should be the problem on the compiling server. Our engineers checking and fixing it, will inform you when it is fixed.


Hi henkjs,

compiling server is fixed, you can upload the program to the mBot now.



I am having the same issue, I press ‘upload to arduino’, ‘Compiling…’ popup appears but nothing happens…
Do I have to install something else in my chromebook?

thank you


Hi jigoa,

We have tested upload program to mBot on Chromebook, everything works okay.
On your side, do you mean you can upgrade firmware successfully but still can’t upload your own program?

You may download it from this link and totally install again have a try.


I’ve done it several times but it wasn’t the problem. I’ve disconnected from the wifi of my company and connected to my phone and it worked. It’s weird, because I was navigating normally but it wasn’t compliling…

soooo, it is working now, thank you!!


Sos cant really know what your talking about do you have a usb import. You also need to download mblock coding app. You don’t see the mbot in My pc . To connect to the programing program mbot you need to connect in the connect icon at the very top



I`ve connected the MBot to the Chromebook. With the USB connection is perfect but when I want to upload to Arduino it keeps compliling. I don´t know what to do.
Could you help me?
Thank you!


Hi Esti,

Here we have checked the compiling server,everything is okay.
Could you please kindly try again?
Once still the issue, you may check if you have installed the other extension.



We are trying to upload to Arduino from a Chromebook. We are from a High School, and it seems that it could be a firewall… The technicians ask where the compilation is made… could you give me this information?
Thank you so much.


Hi Esti,

Do you ask for the domain address of the compiling sever?
If yes, it is arduino.compile.makeblock.com.



We continue with the same problem.
Technicians ask for more requirements in order to test.
Could you tell me the IP adress of the compilator and the PORT, please?

I hope this information would be available for us.
Thank you !


Hi Esti,

The IP is and the port number is 80.


Thank you for the information. However, we can´t connect with the school Wi-Fi.
We can do it with private Wi-fi…



Hi Esti,

Sorry to hear that!
There must be some special settings of the school Wi-Fi prevent using it.
In this way, it is really hard for us to provide any suggestion, hope the network configuration technician can figure it out.