mBot bluetooth connection problem in w7ultimate



Although I can connect through bluettoth with makeblock APP (android and IOS).

I can´t connect through bluetooth in Windows 7 ultimate.
In mBlock v3,4.11 I have tried “discovering” and I find the makeblock and “time out” is shown after trying to connect. I have also tried adding it to windows and clicking on the COMX in mBlock, but it is not “checked” after selecting it.

I have created some simple movements with keys through bluetooth (turn right with right arrow, …) and upload the software to mBot.

Only makeblock extension is selected, mBot board and I have instaled Arduino driver.



Hi posewadone,

Is there any problem to connect the PC to the Bluetooth signal from other devices (instead of the mBot)?
Besides, please try restart the mBlock software and reconnect the mBot Bluetooth more times have a check.

Once it still can’t be connected, I am afraid that there may be compatible issue between the mBot Bluetooth and the Bluetooth adapter on your computer since the robot Bluetooth works with other mobile devices.