I need help with programming mBot


I have a problem, I’m a newbie, I have a Mbot and Mblock, everything is connected at the right spots and everything worked perfectly, i made songs,I downloaded them in the Mbot, it worked, I reseted the Mbot, I programed and downloaded the light, it also worked, I reseted the Mbot again, next I tried to make the motors moves individuals,once again I downloaded and this time it doesn’t worked (the Mbot didn’t moved), so I reset the Mbot (it moved again), I tried again with another script
(Mbot program
wait until ir remote A pressed
*set motor M1 speed -225
wait 0.21 sec
set motor M1 speed 100
wait 0.76
set motor M1 speed 0
to make it turn and it worked only when:
-it’s connected on the computer
-the script (after the *) is detached and I click on it
if I try with the remote (yes the remote’s and the Mbot’s batteries are full) it won’t move a bit… so I need to get help, if someone know how to do, please, PLEASE help me, thanks!


P.S sorry I can’t upload pictures


Hi TangGuy21,

Do you mean the same program works when mBot connected to PC with USB cable, but not work if it is disconnected from PC?
If yes, I am afraid the problem is still on the power though you mentioned the battery is full. Normally, the robot need more power to drive motors than to make voice or lit up light.
May I know which kind of battery do you use? Is it possible for you to change brand new battery have a try?
According to our test and research, it is suggested to use rechargeable Li-ion battery or rechargeable nickel-metal hydride, nickel-cadmium which can be bought from amazon or local shop. Or Alkaline battery with good quality like Energizer, DURACELL.


I used “aerocell” batteries and nos I’ve changed to “énergizer” but the problem still here… the A button on the remote still don’t do anything so once again, if someone can help me, please do it

Tang Guy21


Do you have a smartphone or tablet? Try the Makeblock app to control the mBot instead of using the IR remote.


I’ve got an I-phone and the app Makeblock, the app works perfectly but there is no A button so it can’t help me this time


Ok, there is no A button on the smartphone. However, you found out that the mBot drives forward when you control it with the smartphone. That means the mBot itself is ok. If it just does not react on the A button from the IR remote (and the other buttons work), I guess the A button is broken.


Hi TangGuy21,

Here is an instruction to test if the IR remote controller is okay or not.8. How to judge if my IR remote controller is ok.docx.zip (10.7 KB)
You can refer to it to test the button A, if there is red light when press the button A, the button A should be work.

Besides, does the mBot works with default program while you press the button A on the controller?


the remote works perfectly:
I have a starter kit and the light turns on when I push any buttons so the problem isn’t here
Are you sure the problem isn’t anywhere else?


Hi TangGuy21,

Base on above troubleshooting, there should be no problem on the mBot as well as on the IR remote controller.
Is it possible for you to take a video to record your the whole process (the program, the process of uploading program for mBot and controlling the mBot, the strange behaves on the mBot), it may be helpful to locate the cause.


I ma sorry but I told you I can’t upload pictures


Hi TangGuy21,

You may take the video requested and send it to us (daisy@makeblock.com) via the pCloud transfer website.