Frustrated by the 2.4 GHz module


I recently purchased an mBot and I’ve really enjoyed my early explorations. I was able to install the Makeblock libraries from github in my Arduino IDE install and I’m loving the fact that I can program it exactly like an Arduino Uno. I’m also a huge fan of Scratch and I’m impressed with mBlock.

I bought the 2.4 GHz version because I’m testing this robot for use in the classroom. While mBlock establishes the connection just fine when I use a USB cable, I cannot get a connection via the 2.4 GHz module.

Does anyone have any advice on how to diagnose this problem?



I use this in many classrooms with the 2.4Ghz wireless so maybe I can help you. I’m just going to list a bunch of things since I can’t diagnose it.

  1. Plug in the USB. Make sure that it connects to your computers. Are you using a Mac? This might be an issue. PC works no problem with me so far.

  2. Turn on your mBot with the 2.4Ghz chip installed. The light on the 2.4Ghz chip should go on signifying that it’s talking to the USB.

  3. Turn on mBlock. Go to Connect -> 2.4Ghz Serial --> Connect

  4. If this does not work, hook up your USB cable and connect. Then go to Connect -> Upgrade Firmware. Repeat from Step 1 again.

This is what I would do if I was unable to connect. So far it works for me and I hope it works for you.


Keith, I had the same problem at first. Here is what works for me.

  1. Connect to the mbot from your computer using the USB plug and cable. Make sure the USB connection works: turn on the mbot and choose Connect - Serial port - and choose the USB driver (it sounds like you have gotten this far).
  2. Run the program: Upgrade firmware from that same menu. A new little window appears and that software is uploaded to the mbot via the USB connection. It takes 20 seconds or so and then says done - so then close that window.
  3. With the Wifi dongle plugged into your computer and the mbot on, the light on the mbot’s wifi module will stop blinking and be on.
  4. Go back to the Connect menu - Serial port, and UNCLICK the serial connection port. That connection must be turned off before the wifi connection can be activated.
  5. When you are sure that the serial connection port is turned off, choose Connect - 2.4G Serial - Connect. Check that the check mark stays on - for me it often does not stay on (i.e. connected) every time, but eventually it will.
  6. With the serial USB connection off and the 2.4G connection on, you will now find that you can run the mbot “on-line”. That is, starting the command sequence with a choice from the Events category of commands: “When green flag clicked”, “When SPACE key pressed”, etc.
    Good luck!


This is probably a silly thing to ask, but did you plug the dongle into a USB port? That’s what the wireless module pairs with. :slight_smile:


@chuckmcknight, I did plug the dongle in to a USB port, and even checked the system info to make sure it was being seen. It is.


@eric03, I would never have thought about step 4. Thank you. I’ll give that a try.

#7, replying to each item in turn…

  1. I am on a Mac, so perhaps that’s an issue. Unfortunately I don’t have a PC immediately available to try instead.

  2. The blue LED on the 2.4GHz daughter board flashes once (or twice) and then turns solid which I think indicates a connection?

  3. When I do Connect -> 2.4GHz Serial -> Connect, nothing seems to happen.

  4. I am able to upgrade the firmware successfully with the USB cable.


Hi manifold,

If you are going to connect mBlock to mBot with 2.4GHz connection, must Upgrade Firmware with a USB connection first.

For the issue that cannot upgrade firmware successfully with USB, Try restart the mBlock or reboot the mBot. Beside, kindly try the mBlock v3.3.0 if you are using the V3.2.2


@tec_support I had no difficulty upgrading the firmware via the USB cable.


@eric03 - No luck. I still can’t get it to connect with the 2.4 GHz module, even if I make sure that I have disconnected the cu.usbxxxxxx connection.


So you checked to make sure the cu.usbxxx connection was off. When you then turned the 2.4 GHz menu item on, did it stay on? For me, I often set it on (the check mark appears) but then when I check another menu item (like checking that the USB connection is unchecked,) and go back to see if the 2.4 GHz connection is still checked, it isn’t. Only if it is still checked is that connection on. Does yours stay on? Then, to use it, you need to start your program with the green flag (Events - choose "When “Green flag” clicked. NOT the “Mbot Program” icon in the Robot section. The Mbot Program icon only starts the program if you are going to upload the program to the Arduino, i.e. not be able to run it directly from programs that are not uploaded. Could that be the problem? Check that the 2.4 GHz connection menu item is still checked and start your program with the Green flag choice in Events. Good luck!


@eric03 - As far as I can tell when I click connect nothing happens at all. It never connects, not even for a moment.

I am using the “Green Flag” event from Scratch, not the “Mbot Program” event.


A further check: When I look at the Serial Port menu item, I see a bluetooth option and a USB option that says /dev/tty.wchusbserial1420. Do you see something like that? And when you choose it, can you make a program starting with the Mbot Program icon that you can then upload to the arduino? OK, probably yes on all that! When you are connected to the mbot via USB, does the top line (like the title of the whole page) in the program end with “… -Serial Port Connected - Saved”? Mine does. And when I disconnect from the USB connection, the title changes to “…Disconnected - Saved”. Now, when I check the 2.4G Serial item, that title become “… 2.4G Serial Connected - Saved”. Presumably yours does not. The blue light on the Makeblock wireless module is on whenever the mbot is on and the wifi dongle is plugged into a USB port, even when the 2.4 GHz option is not chosen. So I would guess that you never see the title change to 2.4G Serial Connected, even though the blue LED is on. One possibility is that MakeBlock sent you a dongle that does not match the wireless code of the plug-in. Can’t think of anything else. But if you tell them what’s wrong, they might be willing to send you a new dongle and plugin. Or you could bite the bullet and buy a new set, but that costs $20 and a couple of weeks. In the past, I have written them directly, rather than using this forum, and gotten some helpful advice, so you could try that. Sorry not the solve the issue directly, though.


I would suggest that removing the USB cable from the mBot is the most effective method of ensuring that the connection is broken. :slight_smile:


I am having a similar problem. v. 3.3.1 of the software; the 2.4G shows “connected” in the title bar, but when I click on “Upload to Arduino”, the error appears (image attached): “Please connect the serial port.”


Hi simile,

The 2.4G connection is not available for upload program to main Board, it is only for online test.

If you want to upload program to main board, please disconnect the 2.4G connection and connect with USB cable, then connect the serial port for the USB connection and you can upload program.


I see. Does the BT module allow for wireless upload? Thank you for your support. The information you provided was not immediately discernable in the marketing content. Wireless to me implied wireless connectivity.


There are no wireless uploads. The wireless connections allow you to use the mBot firmata to send commands over the air from the computer via Bluetooth or WiFi, but you must have the mBot connected via the USB cable if you wish to upload programs to run unattended on the mBot. The reason is the the Bluetooth and/or WiFi modules cannot use the onboard programmer that is required to load the program into the mBot’s memory. When a program is “uploaded” via the USB cable, it overwrites anything else in memory and replaces it with the new program and this is not currently possible with the mBot.


I also am using a macbook, bought a classroom set of the 2.4ghz versions… I can connect and run programs with the USB cable. though cannot run them on using the 2.4ghz dongle… even though it says it is connected… Very frustrating. Is there a solution? I also have a bluetooth version, that I have had working wirelessly, though that also seems to be glitchy if it connects or not.


Hi Jonclark,

Please upgrade firmware for the mBot first with USB connection, then remove USB connection and connect with 2.4G wireless serial, test your online testing program and see if it will work.
Here are two instructions to you for reference.1.How to connect 2.4G wireless to my (11.8 KB)
22. How to Upgrade Firmware for (407.6 KB)