Extension center issues


When I try to upload my custom extension in the extension center I get the error:
required field extensionName in s2e file cannot be empty.
But my file is not missing the mentioned field. So what was my mistake?

Here is the .zip I wanted to upload:
LedMatrixEnhancements.zip (3.4 KB)



A JSON lint shows that your s2e file is not a valid JSON file, which will produce the “extensionName not found” error in the extension system.

Please the site


to find the issues within your file.


Hi bigeyex, thanks a lot for your help. I had not much time during the last days to play with it but now I managed it. My mistake was, that I had some tabs in a c-code section which I didn’t replace with /t. It was hard to find, but now it works…


Sorry, now I’ve another problem. I can use my new block and even compile and run it on the mbot. But after saving and reloading the project the block becomes undefined. What could be the reason for it?


Hi tokschi,

Please make sure you are using the latest verison mBlock sfotware 3.4.5.


hi tokschi
You may be guide initialization a extension ? . i have tried but i can’nt do it


Check your JSON here: JSON validator https://jsonformatter-online.com


https://jsonformatter.org for formatting and validating JSON data.


Hi, the error persist in the upload page “required field extensionName in s2e file cannot be empty.”. I parse the json without error, but the upload page give me the error. them i try to compress the arduino library that come with mblock and give me the same error. There are a mistake in the mblock own libraries? I dont belive!


Hi jesus,

What is the operating system of your Computer and which version mBlock do you use?
Besides, you may paste your extension file here.


i have a Mac 10.13.2. Makeblock 3.4.11.
I send you the zip.
Thanks.PIArduino.zip (19.1 KB)


Hi jesus,

The server does down again.
Our engineer will solve it in one or two days. Sorry for the issue and thanks for your feedback!