Encoder motors keep running on MegaPi port 1 and port 2


#1

I have two Ultimate 2.0 kits for my class. One of them works without problems.

The other starts spinning encoder motors on port 1 and port 2 whenever battery power is turned on (even when not connected to a computer). When I disconnect the motors so that my robot is not driving away, I can without problems use mBlock to control the motor on port 3.

I tried upgrading the firmware from latest mBlock, I downloaded latest firmware from GitHub (V0e.01.015) and uploaded it via Arduino IDE, I tried the firmware suggested here, the result is still the same: port1 and port2 keep running and they don’t react when I try to stop them via mBlock.

When I upload an empty Arduino sketch, then the motors remain still.

What should I do to fix this problem? Is it a hardware problem?


Megapi programming - encoder motor wont stop
#2

More info. When I started with this MegaPi I first accidentally tried to use it as an Auriga and I guess I also once uploaded Auriga firmware to it. But after this I uploaded MegaPi firmware (several times).

Can it be that it has some kind of bad state in EEPROM? How to reset it?


#3

I finally found the solution myself. I cleared the EEPROM, uploaded latest firmware again and after this everything works fine.