Did I burned the Orion board?


#1

As suggested by the tec support in this post, I tried to plug a 12V and 5,4A adapter to my Starter Kit to check if the Bluetooth problems experienced were due to a low voltage from the batteries.

I’m not experieced problems with the Bluetooth now,
BUT
one of the motor doesn’t work. I switched the cable and I saw that the problem is not in the motor, not even in the connection cable, it seems that the problem lays in the pins on the board.

The port that seems faulty is the Motor 1

I tried this short program connected via USB

and only the m2 is moving.

Could the overvoltage or over amperage ruined the board?
How can I check’
thanks, Lauro


#2

Hi Tzoulio
Attached below picture as per previous emails, when you said switch the motor connection, did you switch the yellow interface by unplug the black and white wire or just switch white interfaces?


#3

As said before I used the small program posted in the previous post to test the motors.
The Robot is connected to computer via USB.
I left the black and white wire inserted at one end in the yellow jack and at the other end in the motor.
What I did is I unplugged the yellow jacks from the board and switched their positions.
The result is that always the motor connected to the pins marked as Motor 1 is not working.
Motor 2 is always working.


#4

Hello Tzoulio,

When you run the program, is the blue light beside motor1 interface on?


#5

When I run the program the small blue light beside Motor 2 goes on, but the one close Motor 1 is off.


#6

Hi Tzoulio,
OK,I got it.
Please kindly let me know where & when(the date) you bought the robot kit, and send me the order # & receipt for recording.
And your current address, phone number, email address, I will forward to our sales thanks!


#7

I just sent a message to ntec-support@makeblock.com with all the data you are asking me.
Thank you, Lauro


#8

We have a perhaps related problem. We have run a couple of successful projects, programming the starter kit to do lots of fun things. However now something seems to have gone wrong with the motor control. I am pretty sure I have isolated the problem. Its not a software problem, and the motors both work. Next to the orange motor power supply are 4 leds (on the orion board). The right motor works, when the motor runs forwards or backwards the blue and green leds associated with this motor power supply turn on continously. For the other motor the blue light flashes and the motor stutters and the green light seems to glow at lower intensity and the motor sometimes turns and sometimes does not. Switching motors proves that the motors are not at fault.

We have the latest firmware and have written several little programs and been successful, so I very much doubt this is a software issue. We get the same behaviour if we control the motors using mblock or by writing a c programm using the arduino IDE.

many thanks and looking forward to your input
Steve


#9

Hi robocop,

Does the issue on your board always happen on the left motor connector on the Orion board even after you swap the connection for the two motors?
Could you please upgrade firmware for starter first, then run the mBlock program below and take a video to show the behaves on the Starer and the LED status on the Me Orion board. (you can temporarily disassemble some parts on the starter in order to see the LED status on the board)
image
You can send the video to us (daisy@makeblock.com) via the pCloud transfer website:
https://transfer.pcloud.com/


#10

Hi there,
thanks for your help. To answer your question: Yes the issue is with the left motor connector. If I swap the cable connection for the two motors I get the same behaviour.

I upgraded the firmware and then ran your program. Video is uploaded as instructed. The motor behaviour in response to your program looks perfect. But when I run my program (uploaded as IMG_my_program.jpg) I get the strange behaviour again (video uploaded as VID_my_program.mpg)

many thanks again for helping!


#11

Hi robocop,

According to your video, one motor was attached the metal wheel and the other one doesn’t.
The one with metal wheel doesn’t rotate properly with your program, could you please try following points:

  1. Remove the metal wheel from this motor shaft
  2. Modify the speed value 50 and -50 in your program to 100 and -100, then test both motors.

#12

Hi again, thanks for your follow up. I did what you suggested and all looks perfect. However, the problem is speed dependent. I wrote a program to run through speeds from 50 to 250 in steps of 20 and from -50 to -250 in steps of 20. I have uploaded the mblock code and a video of how the motors respond. I also tested (again) if the issue was motor dependent by switching which motor was controlled by which port on the Orion board (this is not shown in the video). Whichever motor is connected to the left port misbehaves.
looking forward to hearing your suggestions!


#13

Hi robocop,

Have checked this issue.The problem may due to the diode for the M1 port is not stable.
Where did you buy this board? You may contact the shop where it was bought to check its warranty.