I bought mBot v.1.1 . His specifications tell, for Android device, that bluetooth version 2.0 is enought, but I can connect with it only by my Samsung TabS tablet. My phones (android 4.4 and above) can install makeblock and mbot app, they can pair robot but are unable to connect with apps. Can you help me please


Hi alrama,

What is the error when you connect the Makeblock APP on phones to the mBot robot? Make sure the Blue LED on Bluetooth module keep slow flashing while you try connect it to the phones.

Besides, you may try connect mBot Bluetooth via Makeblock APP directly.
On the mobile device, open the Makeblock APP and move it close the the Bluetooth module and see if it can get connected automatically (no need to pair it first). If the Makeblock App can’t connect to it automatically, please click on the option on the right bottom corner to check the detected Bluetooth list by the App, then you can connect through that list have a check.


I have no error. Makeblock and mbot apps, on my phones, are unable to select mbot device. Automatical and manual connection with refresh list show nothing. From bluetooth I can see device and I can pair it, but apps cannot. From my Samsung TabS tablet all apps work fine.


Hi alrama,

Have you disconnected mBot Bluetooth to your Samsung TabS tablet while trying to connect to the mobile device?
Is the Makeblock APP on your mobile devices the latest version?

Besides, you mentioned the APP can’t connect the Bluetooth on all your mobiles, what are the models of your mobile devices? Are all the mobile devices only support Bluetooth 2.0?


Answers in order:
Yes. tablet was disconnected before attempting with phones.
I installed the app from Google Play Store yesterday.
My phone is a Alcatel PIXI 4 (5) with Android 6 . Other phone is a Huawei model. Both of them support only Bluetooth 2.0


I’m sorry. I was wrong about alcatel specification. Searching online seems it supports Bluetooth 4.0 . Huawei model is more than a year old, and it’s a cheap model, so I’m quite sure isn’t a bluetooth 4.0 device .


One more thing, mbot bluetooth led is slowly flash while I attempt to connect.


Hi alrama,

It is normal that there is a blue led keep slow flashing on Bluetooth module before it connected to any device.
As for the huawei mobile phone, could you please give us the correct model? If there is a condition, we will give a test.


Other phone is a Huawei Y550. Thanks for support


Hi alrama,

Please try turn off the Bluetooth under the mobile devices Bluetooth settings.
Then open the Makeblock APP to enable Bluetooth and connect have a check.


Same result. Switched off BT, start app, grant permission to use BT and device list empty. Phone was at 5cm from mbot with blue led flashing.


Hi alrama,

Thanks for your feedback, we have provide feedback of this case to our engineer. If there is any update, will let you know.


Hello, my name is Radek and we started to play with mbot this weekend. Mbot buyed in april 2017 works after first start-up well (builded by my 12 years old son). Connection of bluetooth with Samsung S4 mini or, Huawei Y550 is OK without any problem. But not possible to connect with Doogee Y300 or Doogee T6 Pro. Doogee T6 Pro find mbot for bluetooth pairing but not in app MakeBlock. Tried to restart mbot or phone manytimes without success. Do you have any experience with this kid of phone?


Hi Radek,

Do you use the latest version Makeblock APP
Have you tried to turn off Bluetooth under your Doogee mobile devices Bluetooth settings page, then open the Makeblock APP to enable the Bluetooth, then check if you can find the Makeblock on the APP Bluetooth detected list?


All checked by your info but not any improve.
Makeblock v2.9.4.1 in our all phones installed last weekend.
Samsung S4 mini or Samsung J1 or, Huawei Y550 work correctly.
Doogee Y300 or Doogee T6 Pro still does not bluetooth connect.


Hi Radek,
have the same problem on multiple phones.
Today I found the connection can be established only when the GPS is on.
After switching the GPS off the connection was lost.
Hope it will work for you too!



Thank you for this great advice !!!
GPS switched on then Makeblock app switched on
and it really works well now also on Doogee phones.



I used the mBot V1.1 with bluetooth with success for only two days by connecting to a smartphone huawei P10 lite.
Now the mbot module is enabled, the blue led is blinking but the MBot is not visible to any devices(huawey,iphone, samsung tablet), meanwhile other devices are visibile each ones.

I already change the AA battery, uploaded the last firmware and reset to the default program…but nothing change.

Any idea?


Try to disable Bluetooth on any devices in range except the one you want to use. Very often problems are caused by multiple devices trying to connect to the mBot.


Already tested, no chances.