Bluetooth connection troubles


#1

Hi everyone,
I can’t connect my mCore AND my Me Aurigua to my phone, on the makeblock app, by bluetooth.
I reset the default program and after upgrade the firmware, on both card : it didn’t work.
I’m lost, Idon’t know what to do, can someone help me please.
Best regards
Antoine21


#2

Hi Antoine21,

Did the Bluetooth connection work before? And what is the system and system version on your smartphone?
If it didn’t work at beginning, could you please kindly take a picture for the Bluetooth module you have?

Besides, could you provide more details (see below) for the Bluetooth connection issue:

  1. Does the Blue LED on the Bluetooth module keep slow flashing?
  2. Can the mobile device detect the Bluetooth signal?
  3. If it can detect the Bluetooth signal, then what’s the problem when try to connect to it?

Anyway, here I attach an instruction to guide connect mBot Bluetooth as well as some troubleshooting to you for reference.28. How to connect mBot Bluetooth to Makeblock APP.docx.zip (716.8 KB)
29. Bluetooth can’t be connected to Makeblock App, what’s troubleshooting I can do.docx.zip (162.7 KB)

Besides, here is a FAQ list for mBot to you for reference.


#3

Hi tec_support,
The Bluetooth connection worked before.
My phone is with system Android 6.0.
1.Yes, the blue led on the Bluetooth module keep slow flashing when I turn on the electronic card.
2.Yes, when I go in the app, I activate the Bluetooth and I see the module in the list with four bars of connection but when I choose it, it says : connection failed, retry (with the robot in black and white).
Thanks for your answer


#4

Hi Antoine21,

What is the model of your smart phone?
Have you tried open the GPS on the smart phone, then connect mBot Bluetooth have a check?

Besides, is it possible for you to change the battery for the mCore or Me Auriga in case the Bluetooth can’t get enough power to connect mobile APP.

Once still the issue after tried above, could you still take a picture for the Bluetooth module and take a video to show your operation during Bluetooth connecting and the phenomenon. (You can send the video via pCloud transfer website.)


#5

Hello tec_support,
I have a Huawei p8 lite.
I’ve tried to open the GPS, but it’s still the same.
To power my mCore and my Me Aurigua, I use AA batteries. The batteries are full and I also tried to connect it by powering the card with the usb cable : It still doesn’t work.
What’s your email, so I can send you the video.
Here are some pictures :


#6

Hi Antoine21,

Could you please send the video to email daisy@makeblock.com
As for the power,do you have the 5V/1A or 5V/2A dc power adapter? If yes, please kindly try it too.

Besides, could you connect the mBot Bluetooth with another mobile device have a check too?

Btw, do you use the latest version Makeblock APP V3.1.0?


#7

Hello tec_support,

Did you receive the video?
I tried with different adapter but it changes nothing.

I tried to connect with an ipad and a samsung but it says, like my phone : impossible to connect makeblock_LE.

I use the latest version of Makeblock APP.

Thanks again for your support.


#8

Hi Antoine21,

Yes, I have received the video. But currently I still can’t judge if the Bluetooth module is faulty or not.
Do you mind to have a video chat with you to do further checking via the Skype? If yes, please kindly add my account (1021306172@qq.com). We are available from 9:00~18:30 on working day,China time. Could you let me know your available time? (if there is any problem to add my account, please kindly let me know your skype account).


#9

I thought you should connect to makeblock NOT makeblock_LE


#10

Actually, from Antoine21’s video, I saw he has chosen the makeblock (not makeblock_le). In the Makeblock APP, all the makeblock robot bluetooth signal show as makeblock in detected list now (no matter using Bluetooth 2.0 or Bluetooth 4.0).

The mBot Bluetooth is dual mode, the makeblock_le means Bluetooth 4.0 previously. But now, we name both as Makeblock on mobile devices. Antoine21 mentioned the makeblock_le, he may see it in the pop up error message.


#11

Hello tec_support,

I think the problem is that the Bluetooth module does not work anymore, now it has been one year that I have it so maybe it’s too old.

By the way, I’m going on holliday for 2 weeks so I will not be able to skype, sorry.

PS: you can continue to respond, I will have the wifi for the first week but not the robot.


#12

Hi Antoine21,

It’s okay! In this case, the Bluetooth may be faulty. While, you may still try something more and see if it helps.
Do you have a laptop which can connect Bluetooth?
If yes, please try upgrade firmware for mBot again (with Bluetooth module disconnected),then disconnect USB cable and connect the mBot Bluetooth to mBlock software have a check. Here I attach two instructions for reference.1. How to Upgrade Firmware for mBot with mBlock 3.4.x.docx.zip (691.4 KB)
24. How to use Bluetooth module on mBot to do wireless program on mBlock.docx.zip (12.3 KB)

If it still doesn’t work, we think it is faulty and you may need to buy a new one. Here is the official purchase link for the Bluetooth module. Or you can buy one from local re seller.


#13

Hello tec_support,

I will try what you say when I’m back home.
Will you be still here in two weeks? I don’t want to loose the contact.

How long is the life of a Bluetooth module?
Because mine only have 1 year.


#14

Hi Antoine21,

The Spring Festival coming soon, we will have a long holiday in one week. Hopefully, we can have a conclusion on it this week.
For the Bluetooth module, the official warranty time is six months. As for the life time, there is no determined time, it may last one to two years in normal use. But the actual life time is affected by varies of factors like the using frequency and drop. It is suggested to try not let the Bluetooth module fall during usage.


#15

Hello tec_support,

Thank you for all your help. I decided to buy a new Bluetooth module, I think its life is over.