I get fail when i'm trying to upload the code to makeblock


I have a mbot ranger and I want to upload some code on it and I can’t. it is connected but when i press upload to arduino I get:

Could someone help me?


Are you connected via the USB cable? If not, then you cannot upload to the mBot because the WiFi and Bluetooth modules do not have access to the avrdude onboard programmer.


Yes, I"am connected via usb. I do not underarand why i cannot upload the code…


Hmm, so let’s try a couple of other things.

  1. Make sure the mBot Ranger is powered up using the switch onboard.
  2. What Operating System are you using? If you are using MacOS, there is a special driver that you need to load (link).
  3. Make sure you have selected the mBot Ranger (Auriga) board in the Boards menu.
  4. Run a simple program using the When green flag clicked starting block that turns the LEDs on and off. That will ensure that you are connected to the correct serial port.
  5. If you are able to run the simple program from within mBlock, try to upgrade the firmware (under the Connect menu).

If you are able to upgrade the firmware then you should be able to upload a program to the Auriga board. If this doesn’t clear it up, you’ll need to contact @tec_support for further assistance.


Hi Mihai,

In addition to Charles suggestions, here I post the document with steps of uploading program to Auriga.

Please refer to the detailed steps have a try.
Besides, there’re other two points you can pay attention to while uploading program to Auriga:

  1. Make sure there is no mobile device which connected to the Bluetooth from the mBot Ranger.
  2. Keep the Port 5 on Auriga board is empty while uploading.